Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a problem with my vCenter server. Within an hour of a reboot the VMware VirtualCenter Server service stops. If I restart it… it runs for about an hour, then stops again. The following event is registered in the system event log. The VMware VirtualCenter Server service terminated with service-specific error 2 (0x2).

I'm using SQL2005 Express It’s a VM, windows 2003 Std, 1vCPU, 4 Gb RAM Tomcat and SQL are using lots of memory.

This is a similar problem to the many many repsonce you will find on google - but not the same. My service stops about an hour after a clean, successful reboot.

Ideas?

share|improve this question
    
which version of VC? –  Chopper3 Feb 13 '10 at 0:33
    
vCenter Vs. 4.0 –  Alan Feb 15 '10 at 13:29

2 Answers 2

From what I can gather from google, it may be because the VC starts before the SQL server :

  • Obtain the service name for your SQL Service – in Registry Editor, browse to HKLM\System\CurrentControlSet\Services and look for entries starting with MSSQL. In all likelyhood, yours will be called either MSSQL or MSSQL$SQLEXPRESS (ignore MSSQLServerADHelper)
  • Now browse to HKLM\System\CurrentControlSet\Services\vpxd
  • Open the REG_MULTI_SZ value called DependOnService
  • Add a line called “MSSQL$SQLEXPRESS” (or whatever value you determined above)
  • Ensure that the last line in the value is blank
share|improve this answer
    
I can confirm this is a problem that can sometimes happen. I've done the above and the problem for me went away completely. –  Stephen Thompson Feb 13 '10 at 3:49
    
This is a similar problem… but not the same. My service stops about an hour after a clean, successful reboot –  Alan Feb 15 '10 at 13:27
    
Is there anything in the systems logs regarding the stopping ? –  mat Feb 15 '10 at 16:28
up vote 0 down vote accepted

It seems that I had basicly out grown SQL Express. Moved DB to a seperate SQL server (full, not express) solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.