Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently running a host with 5.0 installed and wanted to upgrade to 5.1. Is there any real issues or concerns I should have in doing this? I run 5.1 on my dev server without any issues but I do host some accounts for a couple of resellers. Would there be any logical reason not to upgrade to 5.1? Perhaps some incompatbilities with a "major" open source package like Wordpress, Wordpress MU, Drupal, Joomla, osCommerce, etc.? From what it looks like in WHM it's mostly some added features. Any security holes in 5.1 to be concerned about?

I'd prefer to upgrade to 5.1 to be current but when 5.0 was installed as the default it raised the question.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I've found 5.1 to run well without any compatibility issues with Wordpress or Drupal. There are some additional benefits in 5.1 if you are using InnoDB too. 5.0 may have been the default for your provider or just for the version of the OS you're running.

share|improve this answer

I upgraded to 5.1 without any compatibility issues as soon as it was stable. Our main MySQL system is the MODx CMF. We also use a couple of third-party systems with MySQL which coped with the upgrade without a hitch.

share|improve this answer

Be careful when upgrading to MySQL 5.1 on whm/cpanel and running joomla. Three tables in each joomla database in my webserver got corrupted: _session, _components and _jos_core_acl_aro; trying to repair ended with no records in these tables so I had to truncate _session and restore the other two from the previously made backup. So don't forget: always get a recent backup. I don't think you should really try this update unless very pressed. Wait for this to get fixed or make restoring this tables in your joomla databases part of your upgrade plan. It seems I'm not the only one who had this problem: http://cmstr.com/be-cautious-when-upgrading-mysql-to-5-1-running-joomla/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.