Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just updated from PHP 5.1 to 5.2 and both drupal and phpMyAdmin stopped being able to save information.

I've checked the mysql user permissions - they look ok. I wrote some simple php to insert a row into a table, and it works, but if I try to do the same thing in phpMyAdmin, it just says "no change". phpMyAdmin will delete rows, select rows, but not insert or update them.

Drupal does the same thing - it will select info from the tables ok, but not insert or update (or delete).

Any ideas? I'm really starting to get desperate!

Cheers,
Marek

share|improve this question

2 Answers 2

Weird one, but it it works if I lower upload_max_size and max_post_size in the php.ini.

They were stupidly high, like 2048MB, but now decreasing to 256MB seems to make it all work again!

Amen!

share|improve this answer

A few things to check, if you haven't already

  • Have you tried reloading the mysql permissions using FLUSH PRIVILEGES;
  • Are you using the same username/password in your PHP script as you are in drupal/phpmyadmin?
  • Can you do any insert/update via the mysql command line, with the same username and password as either drupal/phpmyadmin use

Do you get other errors? I just did a quick test, and got ERROR 1142 (42000): INSERT command denied to user 'permuser'@'localhost' for table 'table1', not "No change" as you describe.

share|improve this answer
    
Hey, thanks for the advice... I've just tried FLUSH PRIVILEGES in phpMyAdmin and got: "You probably tried to upload too large file. Please refer to documentation for ways to workaround this limit." Then I tried it on the command line: mysql> FLUSH PRIVILEGES; Query OK, 0 rows affected (0.00 sec) But it made no difference in the end. All the passwords are identical and definitely work. I'm thinking maybe it's something to do with my php.ini. Maybe it got overwritten with the install. –  Marek Feb 13 '10 at 18:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.