Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here's my named.conf.options file:

options {
        directory "/var/cache/bind";
        dnssec-enable yes;

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };

        # disable recursion
        recursion no;
};

I've tried adding allow-recursion { "none"; } before recursion but this also has no effect; I'm testing it by using nslookup on Windows, and using google.com. as the query (and it returns an IP, so I assume recursion is on). This issue occurs on two servers with similar setups.

share|improve this question

2 Answers 2

Just a quick one to rule out the obvious, do you have an:

include "/etc/bind/named.conf.options";

(or similar) somewhere in your /etc/bind/named.conf ?

share|improve this answer
    
Yep, included from named.conf. –  nbolton Feb 13 '10 at 17:58

If the domain is already in the cache, there is no need for bind to do recursion, which might be why it returns a result even though you have recursion off.

Restart bind (to flush the cache), then try a few queries to domains.

You might also have issues if you're using views and the IP you're querying from is in a different view.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.