Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is what comes up when I try to restart lighttpd

user:/# /etc/init.d/lighttpd restart
Stopping web server: lighttpd.
Starting web server: lighttpdDuplicate config variable in conditional 0 global: fastcgi.server
2010-02-13 22:08:30: (configfile.c.907) source: /etc/lighttpd/lighttpd.conf line: 179 pos: 1 parser failed somehow near here: (EOL) 
failed!

Lighttpd restarts fine when I comment out fastcgi config lines.

share|improve this question
    
apt-get had already installed the php config stuff into the lighttpd enabled folder there for I didn't ned to re-write it into the lighttpd.conf file. Thought i'd mention that for anyone else who gets the same error one day (solved) (will go into it in better detail latter and answer my own question when I have more time) –  Mint Feb 15 '10 at 8:54

1 Answer 1

up vote 1 down vote accepted

As I said in the comment, my fault turned out to be that php was already configured with lighttpd with the config file already being placed into the conf-eneabled folder:

/etc/lighttpd/conf-enabled/10-fastcgi.conf

Just deleting my own fastcgi code inside of /etc/lighttpd/lighttpd.conf fixed my issue, hope it helps anyone else who have the same issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.