Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to configure a home-server for using as sound-server among other uses.

MB is GA-MA74GM-S2 (dmidecode confirmed), with Realtek ALC888 codec on it. As I understand, this soundcard must work with snd_hda driver but it doesn't.

I added 'device sound' to kernel conf, 'snd_driver_load="YES"' to loader.conf (just as in handbook). No 'pcm' or 'hda' can be found in dmesg, sndstat shows no installed devices.

What am I missing? How can I help the system to sing?

UPD: I forgot to mention that I use FreeBSD 8.0 amd64 version.

share|improve this question

1 Answer 1

up vote 1 down vote accepted
  1. Add to /boot/loader.conf line snd_hda_load="YES"

  2. Type in terminal kldload snd_hda

  3. If you have many sound cards select the right one via /etc/sysctl.conf. Set hw.snd.default_unit pointing to right one.

PS. Is sound card enabled in BIOS?

share|improve this answer
    
1,2. snd_driver_load="YES" loads all sound drivers. kldstat shows that there're a lot of snd_* modules, snd_hda among others. 3. No, I have only one sound card installed, the integrated one. LOL. I'm sure, I've checked it dozen times while tried to make sound work on Win2008 R2 RC1. Sound was turned off in BIOS. Thanks and best wishes. –  Yorik.sar Feb 14 '10 at 13:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.