Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a Ubuntu Hardy VPS and I am trying to install PHP5.3 with SQLite. I added the dotdeb PHP5.3 repository and succeeded in installing PHP5.3. But I need to install SQLite as well. When I'm trying to install php5-sqlite3 (sudo aptitude install php5-sqlite3) this is the output:

The following packages are BROKEN:
The following NEW packages will be automatically installed:
  php-db php-pear php-sqlite3 
The following NEW packages will be installed:
  php-db php-pear php-sqlite3 
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 460kB of archives. After unpacking 3027kB will be used.
The following packages have unmet dependencies:
  php5-sqlite3: Depends: phpapi-20060613 which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Remove the following packages:

Install the following packages:
php-pear [5.2.4-2ubuntu5.10 (hardy-updates, hardy-security)]

Downgrade the following packages:
php5-cli [5.3.1-0.dotdeb.1 (<NULL>, now) -> 5.2.4-2ubuntu5.10 (hardy-updates, hardy-security)]
php5-common [5.3.1-0.dotdeb.1 (<NULL>, now) -> 5.2.4-2ubuntu5.10 (hardy-updates, hardy-security)]
php5-suhosin [5.3.1-0.dotdeb.1 (<NULL>, now) -> 0.9.22-1 (hardy)]

Score is 197

Accept this solution? [Y/n/q/?]

Obviously, downgrading PHP is not an option.

Please help me! If upgrading the server to a newer release of Ubuntu makes things easier, that's not a problem.

share|improve this question

do an apt-cache search sqlite ... see if dot deb has a sqlite package.. if not then..

I wrote this blog post last year, most of it should apply for 8.04 as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.