Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two servers on a subnet, one server running Windows 2003 R2 (call it s1) and one running Windows 2008 R2 (call is s2). Both servers are members of the same domain.

  • I can rdp into S2 but not S1
  • I can telnet to S1 and S2 on port 3389 (RDP) and I can successfully connect.
  • I can connect to all OTHER services on S1 BUT not RDP!
  • I tried using IPs instead of FQDNs but no luck either.

    This used to work before I P2V'd my Exchange / Domain controller (client's choice).

Confused.

share|improve this question
    
Have you looked in S1's logs for any error messages? –  Keith Stokes Feb 15 '10 at 13:00
add comment

1 Answer

up vote 2 down vote accepted

What happens when you try to RDP to the 2003 box? Does it just silently drop the connection or does it give an error message?

I've found one of these two methods to work in the past:

Method 1: Guaranteed and Reliable

Delete any occurrances of the Certificate, X509 Certificate and X509 Certificate ID keys at HKLM\System\CurrentControlSet\Services\TermService\Parameters and reboot the Server.

MS KB Article

Method 2: Might Work, worth a try on 2003 boxes if all else fails

Change the port that Terminal Services uses by editing the HKLM\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\PortNumber Registry key. By default this is 3389. Changing it to something like 3388, then rebooting the server, may cause things to kick in OK again.

(Note: using this method, you will have to specify servername:3388 as the Server to connect to via mstsc in future. It may be worth a try to change it back to 3389 to see if that forces it to work again.)

share|improve this answer
    
Thanks a lot for your help. May I ask how you discovered this solution ? –  Hilt86 Feb 16 '10 at 7:18
    
It wasn't me, it was a guy I work with. I think it was just a KB search. –  Jimmy Shelter Feb 16 '10 at 17:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.