Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After installing IIS on my dev system, window xp professional, its asking for username and password while trying to access http://localhost. Can you please help me out. Tried googling and tried may things but could not resolve the issue.

  1. Anonymous access is enabled
  2. iusr_ is given full access to the wwwroot folder
  3. asp.net2.0 has been registered

etc. But still not working. :(

EDIT:
Now the password issue has gone off and shows this: Error Type: Microsoft VBScript runtime (0x800A0046) Permission denied: 'GetObject' /localstart.asp, line 40

Browser Type: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Page: GET /localstart.asp

share|improve this question
    
Just a tought: are you sure it's actually IIS which is answering your request? Maybe some other process bound to port 80 before it, and it wasn't even able to start. –  Massimo Feb 15 '10 at 14:29
    
Initially there was this problem and iis would not start and on running netstat on the cmd prompt, found out that skype was using my 80 port. Have fixed it and verified that IIS is using the port. –  zapping Feb 15 '10 at 14:30
    
Ok. You said the IUSR_MachineName account has full control over wwwroot: it's the website root actually pointing there? And it's the website anonymous user account actually IUSR_MachineName? –  Massimo Feb 15 '10 at 14:34
    
Yes. This problem arises on browsing the Default website. It calls the iisstart.asp and in turn the localstart.asp file. –  zapping Feb 15 '10 at 14:51
    
Can you view a simple, static web page (.htm)? Maybe the problem is related to the ASP interpreter. –  Massimo Feb 15 '10 at 14:54

4 Answers 4

Another try: is there a web.config file in wwwroot (or in a parent folder)? If yes, check if authentication is explicitly defined:

 <system.web>
     ...
     <authentication mode="Windows"/>
     ...

See: How To: Use Windows Authentication in ASP.NET 2.0 (MSDN)

share|improve this answer
    
There is no web.config file. It just has the default IIS files. The ones that come in the wwwroot folder when you install IIS. The localstart.asp and iisstart.asp etc files for the Default website. –  zapping Feb 15 '10 at 16:32

Put a simple test.html (create it there, don't copy from another location) in the wwwroot folder and try to access it.

Check, if the permissions you assigned to wwwroot propageted to the single files in that folder (right-click, Security-tab etc.).

Do you use a virtual directory which points to a different folder which you didn't assign the permissions?

share|improve this answer
    
Have tried putting a asp, html, htm and aspx files under the wwwroot folder. With just a 'hello' text. All these gets displayed while accessing <code>localhost/test.asp</code>; etc. its just that 'localhost/'; does not work it asks for a username and password. –  zapping Feb 15 '10 at 14:54
    
what happens if you explicitly call localhost/iisstart.asp or localhost/localstart.asp? –  Massimo Feb 15 '10 at 14:55
    
Its the same it asks for the username and password. With both IE and firefox. –  zapping Feb 15 '10 at 14:56

Instead of using http://localhost, can you use http://pcname, where pcname is whatever your computer name is.

If you're using Firefox try it with IE instead.

Also try this method (from http://www.msfn.org/board/lofiversion/index.php/t33489.html):

  • Click Start>Administrative Tools>Internet Information Services
  • Expand the left tree, right-click your WebSite>Properties
  • Click on Directory Security, then in "Anonymous access and authentication control" click on Edit
  • Tick "Allow IIS to control password", then OK and come out of IIS.
share|improve this answer
    
The "Allow IIS to control password" is ticked. Its the same while trying with pcname or 127.0.0.1 or 192.168.1.xx it asks for username/password. –  zapping Feb 15 '10 at 15:03
    
But what about the actual computer name (System properties | Computer name | Full computer name) or browser? –  Darth Satan Feb 15 '10 at 15:29
    
i have tried it with my computer name and browser on both IE and firefox it was the same. But now the passoword problem has gone. i get a different message have edited my original post. –  zapping Feb 15 '10 at 15:37

Since you are running on Windows XP Professional, I would try turning off simple file sharing. To access simple file sharing go to Windows Explorer-->Tools-->Folder Options-->View-->all the way down at the bottom there will be an option for simple file sharing. To turn it off uncheck the box.

share|improve this answer
    
How could this possibly help? Blindly throwing crap at the wall and hoping something sticks isn't how this site works. –  MDMarra Sep 27 '12 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.