Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server on my network; let's call it MyServer. I run a utility on my workstation that copies files to MyServer and then writes a log file that says whether or not the files were copied successfully. I set up a network share on MyServer at c:\FileRepository shared as FileRepository. My workstation is set up to run the utility automatically each evening.

However, sometimes when I check the log file the next morning, I see that there is an error The network name was not found. When I log in to the server, I see that c:\FileRepository is still there, but it is no longer shared. I can easily set up the share again, but it's only a matter of time before the network share mysteriously disappears.

I am not responsible for the administration of this server. I am responsible only for making sure the utility works correctly.

What kinds of issues could be causing the network share to simply disappear from the network? MyServer is running Windows Server 2003 SP2.

share|improve this question
    
In response to Greg: Yes, the server is a cluster. –  Rising Star Feb 16 '10 at 14:11

6 Answers 6

I assume you are talking about sending your files to something like, Z:\MyServer\FileRepository, where Z is your mapped drive? Will the utility work with a UNC path, such as \MyServer\c$\FileRepository?

EDIT: I realize I didn't answer the question, and only provided a workaround.

share|improve this answer
    
And it's only valid if he has rights to the c$ share, which generally means local admin on the server. –  mfinni Feb 15 '10 at 17:16
    
I can only assume he has the rights, if he is able to connect and recreate the share. –  DanBig Feb 15 '10 at 17:48
    
Well, apparently, the special account that I run my utility program does have rights to the C$ share. My primary role here is developer, not administrator, but I have been troubleshooting this problem for some time now. As I can access the files using the UNC path that you suggested, I have set up my utility program to access the files this way and everything works. I have other things to work on and this solution makes the program work now. Therefore, this is my accepted solution. –  Rising Star Feb 15 '10 at 17:54
    
Thank you very much, Dan! –  Rising Star Feb 15 '10 at 17:54

There's a lot of things that we can suggest - but you say that you're not the admin for the server. Who is responsible for the admin of the server? Could they be removing the share, either manually or via a scripted cleanup process?

share|improve this answer
    
The admin for this server is very busy. I'm sure he could eventually get to the bottom of this. The reason I'm asking here is to get an idea where I could direct him to start. I imagine that this is likely caused by a script running somewhere. It is definitely possible that it is getting removed manually. What kinds of scripts might likely be responsible for removing my share? If it's being removed manually, is this action likely logged somewhere? These are the kinds of things I seek to find out. –  Rising Star Feb 15 '10 at 16:29

Check what the utility is doing behind the scenes - even if's just by running it manually to see what happens to your share. I've seen third party utilities misbehave in this manner before, and totally hose permissions, reset ownership, etc. Once you've established that, you should permission the share so that the account the utility runs under only has rights to "subfolders and files", rather than "this folder, subfolders and files". That should stop it.

If you have access to the source code of the utility it's even better as you should then be able to identify the offending piece of code that drops the share.

share|improve this answer
    
Thanks. This utility is something that I've been extensively modifying the source code to. This problem happens about once every two weeks and I doubt that the utility itself could be directly causing this kind of problem. –  Rising Star Feb 15 '10 at 20:15

Try addressing the server via its FQDN DNS name, or its IP address directly. Addressing it via an unqualified hostname could lead to it being resolved via NetBIOS rather than DNS, which in turn can lead to less reliable name resolution.

I've seen NetBIOS-resolved machines become invisible for a period when NetBIOS browser elections are being forced.

share|improve this answer
    
That won't have anything to do with the fact that he says he logs into the server, and sees that the folder is no longer shared. –  mfinni Feb 15 '10 at 21:17
    
Gonna go pour me another large coffee. –  Chris Thorpe Feb 15 '10 at 21:45

Is your server on a cluster and you are creating the shares in the computer management applet instead of cluster administrator? Check if there is a "Cluster Service" service that is started.

share|improve this answer

Many reasons. The Admin maybe the one removing the share. Also you maybe setting up the share incorrectly. You should seriously consider having a chat with the Admin.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.