Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to setup an NFS Server on FreeBSD, I have gone through a couple guides to try and get it running but can't quite get it going. I have the server running, but I seem to be having trouble setting up the /etc/exports file correctly. I have tried the following lines and all have given me errors saying that their is a bad line in the exports file when I try and and reload it.

/home -alldirs -network 192.168.1.106
/home machinename1
/home/user -network 192.168.1.0 -mask 255.255.255.0

What am I missing and what should I check?

share|improve this question

2 Answers 2

Your first line looks malformed (you're exporting to a network but it looks like you're naming a host)

If that's not it start with standard troubleshooting: Remove all except one line (start with /home machinename1) & get that working first. Add new lines and reload/test until you find one that breaks it.

When you know which line(s) are causing the problem it's easier to troubleshoot :)

share|improve this answer
    
I have not had any of those lines in the same file, they have all be tried independently –  trobrock Feb 16 '10 at 16:44
    
hmm... now that's strange: The second line is definitely valid (as long as it can figure out what address machine1 maps to). What error is mountd giving you before the "bad line" message? –  voretaq7 Feb 16 '10 at 17:09

What is the exact error message you're getting?

Is it possible there's already an entry for /home earlier in your /etc/exports file?

Despite the error, does /home show up as being shared through exportfs?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.