Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Under my local development environment (Ubuntu) I have a checked out SVN repository.

The files have the owner myuser:myuser.

However, I must use sudo for the "svn up" and "svn ci" commands. Also in doing this, if a new file is created during "sudo svn up", then that file is given default ownership of root:root, which I don't want.

Is it possible to run those SVN commands under my default user account, instead of sudo?

share|improve this question
    
why must use sudo? is there any error message given if you don't? –  lorenzog Feb 17 '10 at 12:46

2 Answers 2

up vote 5 down vote accepted

Have you done the checkout using sudo? Maybe there are still some files with permissions root:root. Just do a chown -R myuser:mygroup <directory> on the repository directory again. Then try again to update.

Maybe you can also post your error message when doing SVN operations without sudo.

share|improve this answer
    
Thanks. I did the chown (not chmod that you indicated, right?). I think the problem was I had never done a chown of the parent directory, only sub directories. –  eoinoc Feb 17 '10 at 15:19
    
You're welcome. Ooops. Of course chown. :-) –  cwo Feb 17 '10 at 15:25

Are all files really owned by myuser, or is the .svn folder (which won't appear unless you do ls -la) owned by someone else?

Even if the .svn folder looks right, chown -R myuser:myuser . (note use . not *) in the checkout folder should fix it. There are a lot of files in various subfolders of .svn that could be causing the issue.

Or there's always the obvious option... are the files owned by myuser but you're logged in as someone else? :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.