Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Yesterday we had a power failure and the UPS did not work (it has worked perfect before). Everything seem to be ok when I started all the servers again except of the mail, when I try to mount the store I get the following message: “The database files in this store are corrupted”

Server: Exchange 2003 running on a Small Business Server Latest full backup: one week old Backup program: Backup Exec 9.0

This is what I have done:
1. Copy every file in the MDBDATA folder (edb, stm, log)
2. Run Eseutil /d for priv1.edb
3. Run Eseutil /p for priv1.edb (took seven hours)
4. Run Isintig –fix –test alltests, now it breaks down. Isintig fails with the following error: Isinteg cannot initiate verification process. Please review the log file for more information. The problem is that there is no log file created.
5. Giving up on this route I decide to do a restore from the backup, it fails with the following error: Unable to read the header of logfile E00.log. Error -501, and the error: Information Store (5976) Callback function call ErrESECBRestoreComplete ended with error 0xC80001F5 The log file is damaged.

My conclusion is that E00.log is damage, so how can I repair it so that I can restore the database? Or should I give up and try some other route?

share|improve this question
3  
If you can afford the $300.00 to talk to Microsoft Product Support Services I'd highly recommend it. You're going to spend a lot of time working on this yourself (and taking downtime on email). You may lose a week's worth of email but since you've got a (presumably good) backup they can assist you in getting back up and running faster than Server Fault can. (Nothing against Server Fault, but this is the kind of thing that having "hands on" your machine makes a lot of difference in fixing...) –  Evan Anderson Feb 17 '10 at 17:37
add comment

2 Answers

Are your users connecting to Exchange via Outlook in cached mode? If so, you could restore the IS from your last full backup and let the Outlook clients resync with the mailboxes. This will take anything in the OST file that doesn't exist in the restored mailbox and put a copy in the mailbox.

If that's not an option, then my suggestion is to read this:

http://technet.microsoft.com/en-us/library/bb125070(EXCHG.65).aspx

share|improve this answer
    
Yes, most of our users are using Outlook in cached mode, so that helps alot. I will read that document and see what more I can do. Right now I am trying to do a Eseutil /R to get the restored edb-file from the backup working. –  Markus Larsson Feb 17 '10 at 14:53
add comment

Have you tried mounting without the transaction log, by moving it to a different directory?

share|improve this answer
    
When I try to move E00.log I get this error: The file or directory is corrupted and unreadable. –  Markus Larsson Feb 17 '10 at 12:43
    
Right now I'm restarting the server to see if that does something to the logfile. –  Markus Larsson Feb 17 '10 at 12:49
    
After restart I can move E00.log and try to mount the store, I then get this error: Information Store (3704) First Storage Group: Attempted to attach database 'D:\Exchsrvr\MDBDATA\priv1.edb' but it is a database restored from a backup set on which hard recovery was not started or did not complete successfully. So, now the question is can I finish the hard recovery, and what about the moved transaction logs? –  Markus Larsson Feb 17 '10 at 13:16
2  
If you can't move the file itself, sounds like the filesystem itself is corrupted. Have you chkdsk'ed the volume? –  Bart Silverstrim Feb 17 '10 at 13:16
    
Se my previous comment that I made the same time as yours. –  Markus Larsson Feb 17 '10 at 13:34
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.