Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently trying to get iis 7 to work, but every time I request a page, the application pool goes into stopped status.

In the event log this is what comes back.

The Module DLL 'C:\Windows\System32\inetsrv\defdoc.dll' could not be loaded due
to a configuration problem. The current configuration only supports loading 
images built for a x86 processor architecture. The data field contains the 
error number. 

I've already re installed iis, any other ideas, I read that someone fixed this by downloading the dll again, but this seems like an odd solution.

Thanks.

EDIT

I have now replaced the file with one I downloaded off the internet, and now it says

The Module DLL 'C:\Windows\System32\inetsrv\protsup.dll' could not be loaded due to a configuration problem.

I hope I don't have to get 100's of these.

share|improve this question
    
Is this on a 64bit or 32bit architecture? –  MattB Feb 17 '10 at 14:33
    
32bit, thanks very much –  optician Feb 17 '10 at 14:36
    
Thanks to this article mvolo.com/blogs/serverside/archive/2006/10/19/…2200_service-unavailable_2200-errors.aspx, I found this page technet.microsoft.com/en-us/library/cc735139(WS.10).aspx. This led me to download err.exe and this was the output. –  optician Feb 17 '10 at 15:03
    
# for hex 0xc1 / decimal 193 : SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION bugcodes.h SQL_193_severity_15 sql_err # The object or column name starting with '%.*ls' is too # long. The maximum length is %d characters. ERROR_BAD_EXE_FORMAT winerror.h # %1 is not a valid Win32 application. # 3 matches found for "000000C1" –  optician Feb 17 '10 at 15:03
    
more problems, forums.iis.net/t/1163910.aspx –  optician Feb 17 '10 at 15:15

3 Answers 3

up vote 0 down vote accepted

It really just seems like your IIS installation (or at least the IIS dlls...) are corrupted.

I would perform the following steps to try and get a "clean" reinstall:

  1. Stop IIS
  2. Uninstall IIS
  3. Delete the c:\windows\system32\inetsrv directory
  4. Reboot
  5. Install IIS
share|improve this answer
    
Thanks, will try it! I was thinking of doing that, but was a bit worried that the files would just be corrupt again. –  optician Feb 17 '10 at 15:15
    
Hmm, it seems like the inetsrv directory was already gone after step 2.. Oh well will try install and reboot. –  optician Feb 17 '10 at 15:48
    
@optician: I would reboot before the reinstall too. –  MattB Feb 17 '10 at 15:55
    
I rebooted after every change, and also tried specifically asking asp.net to be installed with iis. Exactly the same error message about defdoc.dll. I think I may have to re install windows 7. i'm still running on the beta, but have a full copy. Bit of a pity. –  optician Feb 17 '10 at 16:12
    
@optician: well, what do you expect from a beta :) –  MattB Feb 17 '10 at 16:16

Im MY case this is propably related to incorrect config files as i moved IIS installation from another server and used that shared configuration functionality.

IIS versions were the same.

App pools are stopping right after trying to go to any site that server runs. Every site has its own application pool. Oh, i tried to set app.pool settings to allow 32bit applications just for the test but it didn't have any effect. Obvious in this case because setup worked well before and i had not changed that setting..

BTW. Seems that general windows server administration tasks has gone out of hand what one man can handle. It might be the direction that there is more specializing in the future. Like plain IIS admins, security admins, AD admins etc.. Im glad if that IS the case somewhere. I'm trying to handle all MCITP:EA materials and this seems to take all of my time. And it's not still even close to enough..

Im MCSE 2003 allready. And having headaches with post 6 versions of IIS..

share|improve this answer

ive seen the same error message. go into your app pool and be sure that you have enabled both 32 bit and 64 bit apps. next, if you are calling any 32 bit DLLs from your app and you are on a 64 bit machine you need to plop the 32 bit DLLs and any dependencies into the SysWow64/inetsrv folder along with any config files they may need. this did the trick for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.