Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am pretty much a total "serious" networking newbie, so I am sorry if this is really stupid.

I bought a Gigabit PowerConnect 2824 switch and tried to install it onto our very small start-up network, and I can't get it do more than 100Mbit speeds.

As part of installing, it seemed to be by default switched to unmanaged mode, so I kept it that way. We have a router connected to the network and it's a Linksys 100MBit router (also a wireless hub for us), this is also our Internet uplink.

Now for the question -- do we need to switch the switch to run in managed mode to get the Gigabit performance and is it the router that is slowing things down? Or is it some other problem?

share|improve this question
    
Thank you so much for all of the answers. I posted some of the questions back in dyasny's post. –  Artem Feb 17 '10 at 16:15

5 Answers 5

up vote 1 down vote accepted

What are you testing the link to link endpoints for speed? I mean, are all your links you're testing between 1 Gbit? You can only get 1 Gbit between two or more machines with gigabit network cards. The router will never go above 100 Mb since you said that's what it at most supports (so your wireless connections will be stuck going through a straw connecting to a firehose anyway).

If your workstations have gig cards and you can verify that they're working properly, you can try manually setting them to a gig connection full duplex, disabling the auto negotiation.

You might also want to test your wiring to the switch to make sure the wires and connectors are secure and of high quality.

It is possible the linksys is interfering; it looks like we had an issue where someone had a small hub for testing some systems hooked up to a Cisco switch in our MDF room and it caused all sorts of problems where the switch was confused because of that hub having multiple systems coming off one port. Why? I don't know, I didn't handle the issue, just had the report after the fact, but I know it caused at least one room to have huge connection and performance issues between their lab and the NAS in another building. The best way to test that is disconnect the linksys from the switch and see what 2 or more wired workstations are getting for performance in transferring files and pinging each other after a reboot or two (and restart the switch) to flush cached tables and such.

share|improve this answer
    
How do I see the auto-negotiated speed and how can I manually force a speed? That seems useful for testing. –  Artem Feb 17 '10 at 16:34
    
Depends on the operating system and network card. In Windows XP, you can go to the control panel, network connections, right click the connection and go to status, and that will give you the connection speed. To force a speed you can try the properties of the connection and configure the card (not one of the protocols) and from there...it depends on the driver. Some have it as a property to change, some have it as a tab, some drivers have a utility that can change it. –  Bart Silverstrim Feb 17 '10 at 16:50
    
You might have to google the specific network card's name and keywords like "force connection speed" or "autonegotiation", something like that with your operating system to narrow down some leads on how to set it, or the manufacturer's site. –  Bart Silverstrim Feb 17 '10 at 16:51
  1. If the router is 100mbps, the sonncetion to it will be 100 as well
  2. The switch is configurable, try to check the settings
  3. Does the cabling support 1g ethernet?
  4. As I always say - contact Dell. this should be #1 really
share|improve this answer
    
The cables all seem to be 5e. So can you clarify, the router limits the speed of connections that go through the switch? Even if both of the end-points are connected to the same switch? So does that mean we need to get a Gigabit router? Do we need to get some kind of moderately serious router in order for it to work well with the PowerConnect switch? –  Artem Feb 17 '10 at 16:15
    
no, I meant that the communication to the router would be 100mbps. which is not trivial to some, no offense meant –  dyasny Feb 17 '10 at 17:30

For Gigabit speeds the requirements are that both the switch and the network card or other switch port that it's connected to supports Gigabit, and that the cable be Cat5e or higher. For gigabit in a business I prefer pre-made and tested cables as a simple connection test with a cheap cable tester is not enough to verify that the cable has the signal integrity to support gigabit speeds. However I have my house wired with Cat6 Gigabit and the end points are punched into Cat5e patch panel and wall ports and all cables are hand crimped to the computers.

If all of these things are true and you're not seeing the link negotiate to 1 Gigabit then you'll need to trouble shoot the issue to rule out a problem, in order of likely hood: bad cable, bad NIC in computer, Bad or mis-configured port on the switch, general switch issue. This last one would be pretty rare if the switch seems to be functional otherwise.

share|improve this answer

Bart and Dyasny gave you some good info, here is a recap and some more.

1) You need PC's / devices that have gigabit interfaces to get the switch to go to gigabit speeds.

2) Any traffic through the LinkSys device will be at a max of 100 mbit.

3) You will need cabling that supports gigabit speeds.

If you have all of the requirements, you can troubleshoot the connections some with a sniffer like wireshark to see the initial negotiations when you plug in the cable. This is limited in use, and may not even work. The best troubleshooting method is an expensive network tester. Fluke makes some of the best ones of these, there are many others. You might want to contact a wiring vendor to help you troubleshoot this as it would be cheaper to pay for their labor than to purchase the tool. Just make sure they come with a quality tool.

share|improve this answer

Re: How do I see the auto-negotiated speed and how can I manually force a speed? That seems useful for testing:
On Windows:
1. Go to hardware section (Control Panel => System => Hardware => Hardware manager OR right click on "My computer" => Properties => Hardware =>Hardware manager). May be another names - something similar
2. Select you network card
3. Find "Additional" part (Or something similar)
4. Choose "Media Type" (Or something similar)
5. Choose your speed from the drop list (Default - Auto)

share|improve this answer
    
On BSD systems: ifconfig will show the speed (usually on the media: line). On Linux: You probably need to run ethtool –  voretaq7 Feb 17 '10 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.