Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tried 10 different emails hosted at Google, Yahoo!, GoDaddy, and some that are privately hosted, and each time I get the following errors. I have blocked sensitive information, but you will be able to see the errors.

Feb 16 17:06:50 xxxxx sendmail[31824]: o1GM6ovJ031824: to=jxxxxxd@att.net, ctladdr=www-data (33/33), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30054, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (o1GM6oJo031825 Message accepted for delivery)
Feb 16 16:54:19 xxxxx sendmail[31625]: o1GLsJPP031625: to=jeremy@hxxxxxc.com, ctladdr=www-data (33/33), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30097, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (o1GLsJah031626 Message accepted for delivery)
Feb 17 09:05:52 xxxxx sm-mta[10620]: o1H6Z3jM005734: to=<jeremy@hxxxxxc.com>, ctladdr=<www-data@xxxxx.corenetworks.net> (33/33), delay=07:30:49, xdelay=01:15:36, mailer=esmtp, pri=571331, relay=aspmx3.googlemail.com. [209.85.222.4], dsn=4.0.0, stat=Deferred: Connection timed out with aspmx3.googlemail.com.
Feb 17 10:35:23 xxxxx sm-mta[12828]: o1HEZwn8011833: to=<jxxxxxd@att.net>, ctladdr=<www-data@xxxxx.corenetworks.net> (33/33), delay=00:59:25, xdelay=00:12:36, mailer=esmtp, pri=300353, relay=aln-mailrelay.att.net. [12.102.252.75], dsn=4.0.0, stat=Deferred: Connection timed out with aln-mailrelay.att.net.

If you take a look, they all send, but then (HOURS later) I get an error "stat=Deferred: Connection timed out with {server}". I'm at my wits end, because I use this same setup on each of my servers, and they all work.

share|improve this question
1  
Can you telnet to any of the remote mail servers on port 25 and have a SMTP conversation with them? If not, this is your problem... –  voretaq7 Feb 17 '10 at 16:32
    
You know what, I can't. Why would that be? I am using the same configuration that my other servers are. –  Jeremy Boyd Feb 17 '10 at 17:27
1  
Do you have any firewall rules controlling your outbound connections? Maybe the traffic is being blocked –  einstiien Feb 17 '10 at 18:12
    
If you're trying this from a residential Internet connection, be aware that most providers block access to outgoing port 25 nowdays in an effort to fight spam zombies. You'll have to use a relay server that listens on, say port 2525, to get your mail out. Or upgrade to a business account (which normally also comes with a static IP) –  jamieb Feb 17 '10 at 19:23
    
I shut off the firewall, still nothing. And it is a dedicated server, not hosted on a residential connection. –  Jeremy Boyd Feb 17 '10 at 19:58

2 Answers 2

if you cant use port 25 you can normally use port 587 as this is the SMTP delivery port that was designed to be used between servers.

Test that out if your ISP block port 25.

DNS looks to be working also as it returns the IP addresses of the remote servers. Yes, test port 587 and send out on that port instead.

edit: tested it works for me on 25.

~$ telnet aspmx3.googlemail.com 25 Trying 72.14.213.27... Connected to aspmx3.googlemail.com. Escape character is '^]'. 220 mx.google.com ESMTP q20si8879349rvl.138

share|improve this answer
    
sorry didnt see the other comments about in the same rack as your other servers. Maybe worth testing the other port and asking if it is blocked accedentally. –  Doghousedean May 25 '10 at 16:57

I have no idea how to read a Sendmail log, but this is what it looks like to me:

The first two lines indicate that the server you're sending through (127.0.0.1 - localhost) accepted the client email for delivery to the remote systems. These first two lines indicate that the local server (yours) accepted the email from the email client (which may be the server itself). It doesn't indicate that a connection has been made to the remote systems and that the remote systems have accepted the email.

The third and fourth lines indicate your servers' outbound attempt to deliver the email to the remote systems and indicates that the emails are being deferred at the remote systems.

It could be that the remote systems are graylisting your incoming emails. What's the outbound FQDN of your server? Do you have A, PTR, and SPF records set up in your public DNS zone for this FQDN?

As voretaq7 suggested, can you establish a telnet connection to port 25 from your server to the remote systems and carry on a successfull SMTP conversation (try sending a test email while connected via telnet)?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.