Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a setup at home with an ESXi server Freenas server and several win7 clients.

I have a domain I set the @ and WWW domain record to my (current) IP address. I then forwarded port 80 to my local win2k3 server on my Linksys router and used host name matching to run the 5 test sites I have. That all works.

Now I want to use the turnkey machines and move to dedicated VM servers. One for a wiki one for SVN etc.

So how do I get to go to one internal IP address and to different internal IP address, while they both use the same external IP address? I added the additional record for wiki to my domain and pointed it to @.

I figured it had to be involving a real firewall. So I installed PFSense on a VM and set it on the DMZ on my Linksys.

From this point I haven't had any luck. I thought that maybe it would be in the DNS Forwarder or maybe in the Rules sections but neither have worked. Am I doing it wrong or on the right track but am missing something.

Thanks for all the help.

share|improve this question
Can you get additional external IPs from your ISP? Otherwise, a reverse proxy server such as Chris S recommended might be your only option. – KJ-SRS Mar 1 '11 at 18:17

You need to have one reverse proxy on the front end that takes all reqests, figures out what the destination is by the host header and forwards it to the appropriate server. You can use software like nginx, ha-proxy, or squid; or a hardware device.

share|improve this answer

you can use 'host headers' on the web server.

share|improve this answer
Thats what I am doing now to run multiple sites on one server. I want to run multiple sites across different servers. When I set redirection up on the IIS config it gets in a redirect loop since the other server has no DNS path. (I probably used all those terms wrong :) ) – efbenson Feb 17 '10 at 20:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.