Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We are trying to move users off Exchange 2007. Following various guides online, we've changed our Accepted Domain to be "internal relay" and created a "Send connector" to relay unhandled email for our domain to an external smart-host.

We then disabled the Mailbox for one Exchange user. The AD user is kept, just the Mailbox disabled (which says it removes mail-user attributes from the AD user).

Several people in the office are using OS X Mail (Snow Leopard with Exchange integration). When sending new email from that client, all works as expected. The email is forwarded to the external smart-host and lands in my Inbox outside exchange.

But for people who are using Outlook clients, sending new email to my account results in a "Delivery has failed to these recipients or distribution lists" message. The error is:

IMCEAEX-_O=FIRST+20ORGANIZATION_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+
28FKODFHF45SPDLT+29_CN=RECIPIENTS_CN=myusername@company.com
#550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found ##

My guess is that Outlook is caching a direct reference to the deleted user in the address book or elsewhere, causing routing to be ignored. Does that sound right? If so, is there a way to force Outlook to update itself? If not, any other ideas?

Or maybe the issue is that Outlook references the remaining AD user account even though there is no more mailbox?

Edit: A bit more information. When I look in the Message Tracker I see that:

Email sent from Outlook clients to the disabled Exchange mailbox have a recipient of: IMCEAEX-_O=FIRST+20ORGANIZATION_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+ 28FKODFHF45SPDLT+29_CN=RECIPIENTS_CN=myusername@company.com

Email sent from Outlook clients to normal Exchange mailboxes are just 'theusername@company.com'

Email sent from OS X Mail clients to either enabled or disabled mailboxes have normal recipients like 'myusername@company.com'.

share|improve this question

4 Answers 4

I had a similar problem once when a user had been moved to a different Exchange cluster, but Outlook had cached the previous reference and kept trying to send to the previous cluster, even when I specifically selected the user from the Global Address list.

The way I fixed it was in Outlook, start typing the user's name until it auto-suggests the username, use the arrow key to select the name in the auto-suggest list and hit Delete. Try typing the name again and it shouldn't auto-detect it, so you can then select the user from the GAL.

share|improve this answer
1  
If you'd prefer to delete all of these autofill addresses in one action, you can delete the n2k file that stores them (the nickname file). On an XP machine, you'll find that file in C:\Documents and Settings\<username>\Local Settings\Application Data\Microsoft\Outlook. On a Vista or Windows 7 machine, it is in C:\Users\<username>\AppData\Local\Microsoft\Outlook. Just close Outlook, delete the n2k file(s), and restart Outlook and they will all be gone. –  icky3000 Feb 18 '10 at 9:00
    
Worth trying. Thanks for the addition icky. Although I realized that the Outlook caching theory doesn't explain why server based mailing lists didn't work either. –  schickb Feb 18 '10 at 16:03
    
Yes usually the NK2 (or in Outlook 2010 the autocomplete stream which follows the user around even in newly created profiles) is the issue here. One can write a powershell script that walks through these files and removes any troublesome X400 entries after a move. Server-based mailing lists has the same issue, if they've been auto-completed once you can still get the issue even if you select it from the GAL manually... –  Oskar Duveborn Jul 18 '10 at 9:02
    
Yes, Outlook (at least up to 2010) caches any Exchange server address (Distribution Groups too) as X500. This was a pretty big hassle when I moved a client to google apps. NK2Edit is the easiest way to do it in bulk. –  quadruplebucky Feb 17 at 8:09

Assuming I'm understanding your question properly, another possibility is that the mailbox you disabled is still being retained. I noticed it when working with setting up Exchange 2010 to work with my current mail system in a similar way you are. Because mailboxes are retained for a period of time after being deleted, an e-mail to that address will return a failure since that mailbox has been deleted and it wouldn't relay the e-mail to my other mail system because of the retained mailbox. If this is the issue you're having, you could probably purge the deleted mailbox, or wait out the retention period.

share|improve this answer
    
A bit scary because then I can't get the account back if things are working (as in my first attempt). I wonder if it could be renamed, or at least the email addr changed when disabled? –  schickb Feb 18 '10 at 16:01
    
I haven't worked with Exchange 2007, but if it's like 2010 in terms of backup/recovery you should be able to just store a backup to recover the mailbox if something goes wrong and you need to bring it back. –  Paul Kroon Feb 19 '10 at 1:13

Well, Outlook keeps a cache of all contacts you send emails to. Outlook pree 2010 the file is locatd in appdata\microsoft\outlook of the userprofile. The file is named like the Outlook profile with the extension .nk2

When seding emails to someone in the same mail orgranisation the nk2 file stores the X400 address of the recipient. google nk2edit and use it to remove all EX references in the nk2 file and i think youll be fine. Or just remove the file. Nk2Edit is free for private use but comes with a license fee for corporate use.

If your using outlook 2010 the nk2 file is in a subfolder to the above called roaming, and the files are Stream_Autocomplete_xxxxxxxx.dat

Hope that helps.

share|improve this answer

I had a similar issue. We are Exchange 2010 and Outlook 2010

We had a GAL sync setup with our head office, for security reasons they separated us off and got rid of the GAL sync.

Since then when we sent them emails either from a contact or even directly typing the SMTP address we got a bounce-back with addresses starting "IMCEAEX-_O%3DNT5_ou%3D0000000000" and "@ourdomain.com" instead of the desired external SMTP address.

The fix is to delete the contact (if it exists) and create a new contact. Put in the correct SMTP address. Then edit the contact and add 'other custom address' put in an X500 address in this format (it does not have to be valid information just not matching your internal X500 addresses):

/O=External Company Ltd/OU=Company name/cn=Recipients/cn=username

Save the contact and that will fix the issue.

Outlook/Exchange 2010 does not use nk2 files it stores that info on the Exchange server. It (for some reason) uses X500 addresses for email routing so if there are old entries for a contact with wrong or missing X500 addresses it causes this problem.

Hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.