Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having issues running an X Windows session on a RHEL5 64-bit server - whenever I execute the command "gnome-session &", the process goes into the background but nothing happens. I have Exceed installed on my Windows machine which is running when I try to start the gnome-session. I've tried just starting firefox by itself instead of the whole gnome session, but it doesn't work either. Any suggestions?

BTW, here's the error message I get when I try to start firefox:

firefox: Fatal IO error 104 (Connection reset by peer) on X server localhost:10.0.

share|improve this question
    
Why are you trying to manually start gnome from the command-line rather than a graphical runlevel? –  Ophidian Feb 18 '10 at 15:06
    
I don't know...I guess because that's the only way I know how to do it? –  Brian Feb 18 '10 at 18:01
add comment

2 Answers

Have you tried issuing the startx command?

You appear to be getting the firefox error as you are launching it without a supporting X session (in your questions, gnome) running.

That's the proper way to start gnome and it should start automatically, if it doesn't than running startx manually will launch the graphical client that is specified in your /etc/X11/xinit/Xclients script file.

Check the startx manual page for more information:

man startx

That should explain how it works and where the default files are located.

share|improve this answer
add comment
up vote 0 down vote accepted

Turns out the problem was due to a corrupt .Xauthority file after my SSH session had timed out. When I deleted the file, logged out and logged back in to SSH, a new .Xauthority file was created and after that I was able to start firefox and gnome-session.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.