Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a complete noob question for postfix, but I have to administer a live installation, and in need of reconfiguring the resend rate.

Help would be appreciated.

share|improve this question

Parameters minimal_backoff_time, maximum_backoff_time and queue_run_delay might help you.

maximal_backoff_time (default: 4000s)

The maximal time between attempts to deliver a deferred message.

This parameter should be set to a value greater than or equal to

$minimal_backoff_time. See also $queue_run_delay.

Time units: s (seconds), m (minutes), h (hours), d (days), w

(weeks). The default time unit is s (seconds).

For more information see the Postfix documentation about the parameters

share|improve this answer

You want the delay_warning_time parameter, set it to say, 4h to behave a bit like sendmail :

delay_warning_time (default: 0h)
       The  time  after  which the sender receives the message headers of mail
       that is still queued.

       To enable this feature, specify a  non-zero  time  value  (an  integral
       value plus an optional one-letter suffix that specifies the time unit).

       Time units: s (seconds), m (minutes), h (hours), d (days),  w  (weeks).
       The default time unit is h (hours).

That is, either do a :

postconf -e delay_warning_time=4h

or edit the file and put delay_warning_time=4h.

share|improve this answer
I'm not sure this is what partoa is looking for -- It sounds like he wants to configure the actual resend (retry) rate, not how long it takes postfix to send the originator a "Hey I'm still trying to deliver that message" email. (I could be misreading the original Q. though) – voretaq7 Feb 18 '10 at 15:47
@voretaq7. True @mat. Thanks, I bet I'll need this sometime too. Can you, you can add the bit for the retry rate too. – partoa Feb 18 '10 at 18:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.