Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can't seem to input the "IIS APPPOOL\PoolName" 'account' into the Windows file/folder ACL setting GUI, it doesn't recognise the account.

I understand that this was a problem in vanilla Windows 2008 and you needed to use icacls, but it's supposed to work on Windows 2008 R2 in the GUI.

See - http://forums.iis.net/t/1156692.aspx

Any ideas?

share|improve this question
1  
@Christopher Edwards: I just checked and this does work on 2008R2 for me. In the GUI window you have options for "object type" and "location" - make sure that "built-in security principals" is chosen in object type, and that your machine name is chosen in location. –  MattB Feb 18 '10 at 19:45

1 Answer 1

I had the same problem recently. After running IISRESET, I was able to assign permissions to the app pool identity accounts through the GUI as expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.