Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am in the planning stages of migrating an installation of Microsoft Dynamics GP 9.0 to a new server. The old server is running Windows Server 2003 R2.

I've been testing installing some VMs to make sure the migration will run smoothly, and run across some hurdles. Any version of Windows Server 2008 allows me to install GP properly, but once I try to install GP service pack 2 using the MSP file I have, I get the message:

"A fatal error has occurred. The Microsoft Dynamics GP installation has ended prematurely."

I've tried with these versions:

  • Windows Server 2008 32-bit
  • Windows Server 2008 64-bit
  • Windows Server 2008 R2 64-bit

I've tried running it manually from an administrator command prompt: msiexec /p en_gp_9.0_sp2.msp. I also did this with UAC disabled, just in case.

When I created a VM of Server 2003 R2, I was able to install the MSP properly. I'll use Server 2003 if I have to, but I would really prefer not to miss out on the newer features in 2008.

share|improve this question
    
@Stephen Jennings: are you sure about the versions you've tried? There is no 2008 R2 32-bit. –  MattB Feb 19 '10 at 3:37
    
@MattB Whoops, got mixed up while editing that list. Fixed. –  Stephen Jennings Feb 19 '10 at 4:38
1  
GP 10.0 is the current version. If the customer is current on their CustomerSource support you should have GP 10.0 available to you, which 2008 compatible –  tegbains Feb 19 '10 at 7:41
1  
@tegbains : This sounds like a stupid question now, but are you saying CustomerSource entitles us to full version upgrades? I believe we might have that, I'll need to look into it. –  Stephen Jennings Feb 19 '10 at 12:39

5 Answers 5

up vote 2 down vote accepted

Doesn't look like it according to this http://www.microsoft.com/canada/dynamics/gp/product/90systemrequirements.mspx

share|improve this answer
    
I'm hoping 2008's absence from that page is only because it was written years before it was released =) –  Stephen Jennings Feb 19 '10 at 3:28

No you must upgrade to 10- "There are no plans to make versions 9.0 or before compatible with Windows 7" Which would have to also include windows 2008 r2

http://blogs.msdn.com/gp/archive/2009/08/04/windows-7-and-dynamics-gp-compatibility.aspx

share|improve this answer

I can confirm it doesn't support Windows Server 2008 R1 or R2. We have to still stick with Windows Server 2003 for GP.

I've not had it confirmed that they will release a 64bit version of the software, but maybe Microsoft will soon, but I wouldn't hold our collective breath.

share|improve this answer

Stephen,

I'm sharing a portion of a post written by a Mr. Chad Bishop at a Great Plains partner site:

"The reason it will not work is because of data execution prevention. You need to turn this off in Server 2008. (Through system properties, advanced tab, performance button.) youll notice right off you cant add .msi files, just executables. heres where x86 will work. you want to add c:\system32\msiexec.exe. (It appears that one can’t simply turn it off completely so you have to add exceptions.) If you are on x64 youll very quickly realize you cant change dep attributes on x64 executables. you cant disable hardware enforced dep on x64 there are no system settings for it. So for x64 your only option is to be able to run gp9 with no service packs."

If you try this, please post your results.

share|improve this answer
    
Jim, Your post does indeed reflect what most of the blogs report and also what Microsoft's official position is...which naturally incorporates what would was found on the MSDN link you provided. However, my post was for those "triers" that seek to persevere. Though I haven't tried this solution from Mr. Chad Bishop myself, his report was promising...and so I share it for those to try. ...and if anyone does, please report back. Thank you, Dai Meagher, CPA –  Dai Meagher Mar 10 '10 at 6:42

I have done this successfully twice. In order to install GP 9 service packs on Windows Server 2008 R2 open a command prompt window with elevated permissions (run as administrator) then enter:

bcdedit /set nx AlwaysOff

Then reboot the server. You should be able to apply your GP 9 Service Packs now.

What you are doing is disabling Data Execution Prevention at system boot. If you require DEP after applying your service pack(s) re-enable it with

bcdedit /set nx AlwaysOn

and reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.