Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working from an openSuse 11.1 box, from an essentially clean install. I'm trying to do an SVN export onto the box over http (via apache). Our SVN server is running on port 8080 on the network, and is up and working fine (can reach it from my windows box, and from an Ubuntu VM on my windows box).

The Suse box can ping the SVN server just fine, and can wget off of port 80. But it cannot reach it on SVN over HTTP on port 8080. And a basic wget against a a web page running on 8080 on the same server fails as well.

I assume there is some sort of network or firewall configuration I am missing, but I'm not familiar enough with these things on *nix to know where to start. Any ideas?

EDIT: I checked from yast2, the firewall isn't even turned on...

UPDATE: Running tcpdump while I try wget a website on port 8080, I get the following:

13:51:55.486329 IP mysusebox.56489 > mysvnserver.http-alt: S 1456704340:1456704340(0) win 5840 <mss 1460,sackOK,timestamp 42587871 0,nop,wscale 6>

And that is the only item in the list after a second or to of trying the wget. The wget eventually fails with a "connection timed out"

UPDATE: Resolved. Turns out there was a hardware firewall between the two. Thanks though, learned something new with tcpdump!

share|improve this question
    
So if I'm reading you right, your Windows and Ubuntu boxes can svn to it over port http/8080 fine? Or is it the svn protocol they're using? –  squillman Feb 19 '10 at 19:02
    
The Windows/Ubuntu work fine... I mention them as proof that the SVN server isn't borked and is in fact accepting connections over 8080. The Suse box is different hardware completely... –  Matt Feb 19 '10 at 19:08
    
What is the response that you get from a wget against 8080? Is it a connection fail or do you get an HTTP response back? –  squillman Feb 19 '10 at 19:20
    
connection timed out - updated above with the info from tcpdump –  Matt Feb 19 '10 at 19:55
add comment

3 Answers

up vote 0 down vote accepted

Turns out the new Suse box was on a different subnet, and a hardware firewall between the two was blocking the port. Sorry for the noise! I'll leave up since the debug suggestions were useful (learned something new with that tcpdump!)

share|improve this answer
add comment

If that doesn't work check to see if the SVN server location is locked down in the Apache config to limit connections by IP address?

share|improve this answer
add comment

I would first telnet to 8080 from the Suse box and see if you can connect to the port. I would also run tcpdump on the Linux server to see if that gives any insights. You could also run wireshark/tcpdump on the svn server at the same time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.