Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Basically the situation is, I have a box running Debian, the box internally has an Intel SCSI RAID controller which is controlling 2 hard drives in RAID1 mode which is where the OS is installed.

Further, I have a QLogic fiber channel adapter that connects the unit to a Fiber Channel SAN.

My process of installation is I'll install Debian to the local drives, and leave the QLogic firmware out of it for the time being.

Then once I get the unit online, I'll install the firmware drivers.

This flops my internal drives from /dev/sda to /dev/sdc, which is a bit annoying, but recoverable. Probably should address these by UUID anyways.

Once I get back online, I have to install multipath-tools (the framework is a multipath framework).

However, once I reboot the machine again, it fails on boot after discovering multipath targets, saying my local drives are busy and cannot be mounted to /root.

Any help in what may be the problem here? Or at least how to disable multipath until after the unit boots and then ignores the internal drives?

share|improve this question
up vote 0 down vote accepted

This appears to be a conflict with multipath-tools-boot and the SCSI controller. The workaround is to use software RAID for the time being.

share|improve this answer

It sounds like you haven't blacklisted your Internal drives in the multipath.conf, you can blacklist by make and model wild card like this

blacklist {
devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
devnode "^hd[a-z]"
device {
    vendor "Intel*"
    product "*"

Modify accordingly to reflect the drives your Intel RAID is presenting. Once this is complete, rebuild your initrd as multipath.conf is copied there. Now when you boot the blacklist should be evaluated, those drives will be left alone and your root should be mounted fine.

Also, as you commented, you should be using UUIDs or FS labels for deterministic mount points, the sdx devices allocation is not designed to be deterministic.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.