Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 10.6.2 server on the internet. I want to vpn into it to get access. I start VPN and it gives me an address in the range I have set

However the server itself does not have a local ip of 192.168.2.x so I cannot ping it or ssh into it or anything.

The machine VPNing gets an ifconfig entry that looks like this:

ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
 inet --> netmask 0xffffff00 

Where I think it should get:

ppp0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
 inet --> netmask 0xffffff00 

I can't find anywhere to set the local vpn IP address. And I can't find a pptpd.conf file either.

Any help is appreciated.

share|improve this question
Some questions: How do you connect your server to the internet? What is it's real IP address? Do you use Server Admin to configure the internal VPN server? – Sven Feb 3 '11 at 0:13
I use server admin to create the L2TP server. The server is connected directly to the internet on a public IP. – gbrandt Feb 3 '11 at 15:14

I 'solved' this by using ssh tunnels instead. Picked up Meerkat to help create the tunnels and advertise services via Bonjour.

Never figured out what was wrong with the VPN. Sorry.

share|improve this answer

Where I think it should get: inet --> netmask 0xffffff00

Nope. Point-to-point connections don't need this. It can be to easily.

share|improve this answer
Every other VPN I have used gives me an address that shares the values covered by netmask. Without it, it seems that I cannot move data through the server. ie when setting 'Send all traffic over VPN connection', I am unable to do DNS queries. I am running a local DNS server on the server and it does pass the DNS entries along. – gbrandt Feb 3 '11 at 15:16
A fact that you never seen a thing doesn't mean it couldn't have happened sometimes. :-) – poige Feb 3 '11 at 15:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.