Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We've got a chroot environment on CentOS set up for our users to download data from. One of our users is using WinSCP and they're getting this error:

"A call to an OS function failed".

This link on the WinSCP Support forum raises the same issue but there's no response. It appears that the problem is that the chroot environment is passing back a double backslash "\" in the directory name, which is confusing WinSCP. Has anyone had the same problem and knows how to solve it?

share|improve this question

migrated from superuser.com Feb 20 '10 at 8:29

This question came from our site for computer enthusiasts and power users.

    
My current suspicion is that it's because the users home directory in /etc/password has a '/' on the end of it but my change hasn't seemed to make a difference. That said, I don't know if I've successfully managed to get sshd to reread /etc/password. –  Anonymous Jan 7 '10 at 20:32
    
any update to this issue? the forum post you link to shows an error when a file is edited. can winscp copy the file OK? –  quack quixote Feb 20 '10 at 5:15

2 Answers 2

This error would rather seem that the chroot is incorrectly set up and is missing essential libraries. What is the config for the service?

Are you using rssh? If yes, older versions of WinSCP could work only with unrestricted shell (one with cp, chmod, etc.), newer versions support SFTP protocol that works OK.

share|improve this answer

In Winscp Go to Options-->Preferences-->Endurance-->Enable transfer resume--> All files Click on OK and then refresh Winscp. The error should not come.

share|improve this answer
1  
Do you have any references or an in-depth explanation why changing the settings in this way would help the issue? In the end, it simply changes the resume settings and does not look very promising at solving anything here. –  the-wabbit Jul 24 '13 at 12:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.