Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In our company, I want to check if users are running web servers on port 80 and 8080.

I downloaded nmap and ran this command:

nmap -p 80,8080 192.168.1.0-255

I got a list of IPs and tried to access them in my browser (EG: 192.168.1.1:8080) but wasn't able to connect.

Is my nmap command correct?

Thanks!

EDIT:

Here's the response:

Host is up (0.050s latency).
PORT     STATE SERVICE
80/tcp   open  http
8080/tcp open  http-proxy
share|improve this question

3 Answers 3

Your NMAP command is fine. It's the service you're trying to connect to that is the "problem".

You can find that a "server" has an open port on 80 or 8080 but still not be able to connect it. For instance, I have about three dozen polycom phones that are accessible at port 8080 but they have bum config files. When someone tries to access them at that port they aren't able to connect.

And it may depend on how you're trying to connect. Even though its port 8080 maybe you aren't supposed to use a browser to connect to it.(I know - crazy idea).

Find out what type of device you're trying to connect to using this (you'll need sudo or root):

nmap -sS -O -p80,8080 192.168.1.0/24

(Farseeker - any thoughts about nmap? ;)

share|improve this answer

Can you post you NMAP output. It may be detecting a web server on those ports but the server may not be serving a page.

share|improve this answer
2  
Try nmap -p 80,8080 -A 192.168.1.0/24 The -A tells it to output more detailed results witch may help determine what is running. –  Shikoru Feb 21 '10 at 6:47

Use -sV switch for version detection. Additionally, use nmap script "http-title.nse" to grab additional information (page title).

nmap --script=http-title.nse -sV -p80,8080 IP_RANGE
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.