Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using the Zend Framework. Lately I installed the last version of the ZF. I try to use zend tool from a terminal in ubuntu. When I do ZF show version I still see version 1.9.6. How can I make sure that the ZF command will use the latest version?

I think I have once added the ZF to my terminal profile but I don't know how to change it.

Can anyone help me?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This is not a bash issue. This sounds like a path issue to me. You didn't mention how you installed version 1.9.6 or how you installed the newest version. So I can only take a guess as to what's going on. But I'm guessing that both versions are still installed to different paths and 1.9.6 is being found first due to how your path is setup.

You can see your current path by running echo $PATH. And you can tell which ZF command is being run by running which ZF. So from there if you know the path to the binary you wish to run it's just a matter of fixing your PATH. I would also suggest un-installing the older version if it's not needed so that it doesn't cause you any more issues.

share|improve this answer
1  
If you want to add something to the path globally you'll want to edit /etc/environment or symlink the binary to /usr/local/bin. If you just want to add it to your user account then you'll want to edit ~/.profile –  3dinfluence Feb 21 '10 at 23:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.