Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just setup a new server and installed vsftpd and created a user account, when trying to log in using FireFTP it appears to accept the username/password, but it never fully connects and sits on "Working...". It times out and attempts to reconnect with no luck. Below are the settings changes that I made.

anonymous_enable=NO
chroot_list_enable=NO
chroot_list_file=/etc/vsftpd/chroot_list
chroot_local_user=YES

Can you think of anything that may be causing my issue?

share|improve this question
    
I think the problem is that the user account isn't being put int he correct directory. Where can I specify this? –  mike Feb 22 '10 at 16:40
    
with the chroot settings you have the user is chrooted to their home directory when they login. As far as the ftp client is aware this is "/". Do you actually see the contents of your systems "/" directory when you connect? If so, does your user have a home directory? –  einstiien Feb 22 '10 at 17:06
add comment

3 Answers

up vote 1 down vote accepted

Is there a firewall on the server? This symptom can be caused by PASV FTP no being able to connect on a second port. Also, try connecting from a command prompt instead of a client program.

share|improve this answer
    
It connects from CMD. I noticed that it puts me in the "/" directory. Is there a place where I can specify what directory the user should be in? –  mike Feb 22 '10 at 16:37
    
If it connects from CMD then I would bet money it is a firewall issue. What OS are you running on the server? Are you connecting over the internet or on your local LAN? As for the directory, I'm not sure, I have the default config on mine and it works correctly. You might want to read through the options here vsftpd.beasts.org/vsftpd_conf.html –  einstiien Feb 22 '10 at 16:43
    
I'm running CentOS and I don't believe it is a firewall issue because I'm able to connect via CMD from a remote PC. I'll read that link to see if anything catches my eye. –  mike Feb 22 '10 at 16:49
    
The fact that you can connect from CMD and not a GUI client does point to a firewall issue. When you connect using passive FTP(which most clients do) the client trys to open a connection to the server on a different port (usually > 1024). Depending on your firewall config this will not work correctly and the client will time out. Read this: slacksite.com/other/ftp.html –  einstiien Feb 22 '10 at 16:53
    
Yup, you nailed it. I had to add IPTABLES_MODULES="ip_conntrack_ftp" to my /etc/sysconfig/iptables file. Thanks so much! –  mike Feb 22 '10 at 17:16
show 1 more comment

Check the log file and see if that tells you what the problem is. Hard to say with the information you provided.

EDIT: I think the problem is that the user account isn't being put int he correct directory. Where can I specify this?"

In the vsftpd.conf look for "user_config_dir". For example:

  • user_config_dir=/etc/vsftpd_user_config

In that directory create a file for that user named the username. Inside that file:

  • local_root=$THEIR_FTP_HOME_DIR
share|improve this answer
add comment

Configure firewall properly its may be firewall issue. you may check http://www.rootlocker.com/complete-configuration-vsftpd-server-access-control-implementation/ link to setup properly the vsftpd server.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.