Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I run my home machine at runlevel 3, as I use Nomachine to remote into it from my laptop. I use s2ram --force to suspend it at night.

When I power it back on, everything works fine - my NX Session is still alive and I can connect again etc. However, the display doesn't wake up. I can still log in blind, but it looks like the graphics card just won't wake up.

Any ideas?

share|improve this question
What graphics have you got? – mm2010 May 25 '09 at 12:29
up vote 3 down vote accepted

This is a known issue already addressed in the opensuse wiki. Some of their reccomended workarounds include:

 - passing acpi_sleep=s3_bios to the kernel 
 - passing acpi_sleep=s3_mode to the kernel 
 - passing both of the above (acpi_sleep=s3_bios,s3_mode) to the kernel 
 - POSTing the video card from userspace after resume using vbetool 
 - getting the video mode number before suspend and setting the same video mode after resume using vbetool 
 - saving the VBE state before suspend and restoring it after resume using vbetool 
 - saving the PCI config space of the VGA card before suspend and restoring it after resume 

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.