Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to configure FastCgi with ligttpd server.

I was able to run vanilla lighttpd like this: ./lighttpd -f lighttpd.conf

And then I compile/install the source of fastcgi, and I add the following in my lighttpd.conf:

fastcgi.server = ( "/fastcgi_scripts/" =>
      (( #"host" => "",
         #"port" => 9091,
         "check-local" => "disable",
     "bin-path" => "/usr/local/bin/cgi-fcgi",
         "docroot" => "/" # remote server may use
                          # it's own docroot

But lighttpd won't start after I add the above.

Can you please tell me how can I run fastcgi with lighttpd? I want to use a c program with fastcgi with lighttpd.

Thank you.

share|improve this question

migrated from Feb 23 '10 at 2:26

This question came from our site for professional and enthusiast programmers.

Does it show any errors? – rvs Mar 28 '11 at 7:42

This is all:

fastcgi.server = ( ".php" => ((
                     "bin-path" => "/usr/bin/php-cgi",
                     "socket" => "/tmp/php.socket"
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.