Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While I'm waiting for VMWare support to get back to me, I thought I'd ask here. I have a 400 gig LUN presented from a fiber channel SAN to my VMWare host. It's legacy from another virtualization platform and I need to keep it as is to avoid a long period of downtime. I formatted my VMFS3 datastore with 4 meg blocks to allow up to 1 TB disks. Then I tried adding my 400 gig disk as a raw device in physical compatibility mode. I get the error:

"File is larger than the maximum size supported by datastore 'Base Test'. [Base Test]VMTEST01/VMTEST01_2.vmdk

Originally I had the VMFS datastore formatted with 1 meg blocks which was the cause of this problem since the largest disk allowed would be 256 gigs. But I deleted the data store and then reformatted with 4 megs blocks. I've also tried using virtual compatibility mode for the raw device but it still fails. Does anyone have any suggestions? I've been waiting for a little over a week for VMWare, but that's fine because I'm not yet a paying customer. I'm still in the eval phase.

share|improve this question
Does it show up as 4Mb blocks under storage configuration in VI Client, or still showing as 1Mb? I had a similar problem aftr reformatting an OpenFiler LUN and it was corrected by rescanning after re-adding. For whatever reason, VMWare hadn't picked up the change of block size. – Chris Thorpe Feb 23 '10 at 22:46
Chris, thanks for answering. Yes, it shows up as having 4 meg blocks and the maximum file size is 1024 G. I'm tempted to just try one more time to delete everything and reformat the data store from scratch like I did before. – George H. Lenzer Mar 1 '10 at 17:32

I'm still testing, but I think the answer is that after I deleted the only data store on the system, I didn't reboot before creating a new one. So it's possible that the partition table didn't get an update. That's a WILD guess. But it's based on my deleting the data store again this morning and then rebooting before creating a new one.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.