Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can successfully navigate to : http://localhost/postinfo.html

Note the html file extension above.

but when I navigate to this existing page:

http://localhost/localstart.asp I am promopt to enter my username/password, which I do but the dialog keeps reappearingeach time I correctly enter it.

When I try to use my external IP address

http://24.63.238.17/postinfo.html with my router set to port forward traffic on port 80 to the IP address of the same machine, I get the followinge error:

The server 24.63.238.17 at UTA200-TM requires a username and password.

Warning: This server is requesting that your username and password be sent in an insecure manner (basic authentication without a secure connection).

I have no anti virus app on this machine and I tried to turn off Windows Firewall.

All of this worked at one time, I am not sure what changed. I am not inclined to think that my ISP is blocking incoming traffic on port 80 as this once worked-of course, it could have changed but I am thinking hopefully...

Can someone help so people outside of my home intranet access my web site?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Check the authentication method you have set in IIS. It looks as though you've selected basic authentication, hence the requirement for a username and password, so you'll need to switch it to anonymous access. You don't say what version of IIS you're using, but the page here (which is for Server 2003) might help with some pointers for setting it up correctly.

By the way, if your machine is accessible from the internet, not having AV installed is a baaaaddd idea.

share|improve this answer
    
Anonymous was and is checked, Basic Authentication was not and remains unchecked. Windows authentication was checked and is not unchecked. When I access localhost/localstart.asp I now get the error: Error Type: Microsoft VBScript runtime (0x800A0046). Scripting is enabled. Permission denied: 'GetObject' /localstart.asp, line 40 I'm using iis 5.1 with XP Prof –  Chadworthington Feb 24 '10 at 12:38
    
line 39 sPath = "IIS://" & sServername & "/W3SVC/" & sServerinst line 40 Set oDefSite = GetObject(sPath) interesting sPath= IIS://localhost/W3SVC/1. I thought that this was was a default pg that should work by default. –  Chadworthington Feb 24 '10 at 12:45
    
You might have more joy with the stackoverflow.com peeps for asp stuff. –  Grizly Feb 24 '10 at 15:50

My best guess is that you have a problem with the user account that IIS uses to execute the ASP code. In the properties for the site, on the Directory Security-tab click the Edit button under Anonymous access. Note the user name for the Account used for anonymous access mentioned here (normally IUSR_*). Check the security settings on the folder to make sure that user has sufficient rights on the website directory (read & execute).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.