Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Good day,

Here is the problem : We are hosting a Microsoft Exchange Server. Everything working fine until recently, where the mail transport seems to go wrong. We almost have to restart the service every morning. The thing is that the transport service is started, but the mail are not delivered to the users and senders to our server get a delayed delivery notification. When we restart the service, all the mail is then delivered to the users and we're good to go for a day or two.

Things I've noticed : The store service is growing to around 6 Gb of used RAM, and the w3wp.exe service is hanging around 700mb RAM.

Is there a way to schedule a restart of the transport role every 4 hours or something while I'm solving the issue so I don't have to worry when I leave for the week-end? And most of all...does anyone have any idea on how to solve this issue?

Thanks,

Philippe

share|improve this question
1  
are there any errors in the logs? Somethings gotta be breaking for this to happen. Also are you fully patched up to the latest version? –  Jim B Feb 24 '10 at 16:05
    
Now that you mention it, my colleague just notified me that there happened to be some errors with the Forefront engine update, and a warning was issued after that saying that : "The Microsoft Exchange Mail Submission Service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time." –  Philippe Feb 24 '10 at 16:28
add comment

2 Answers 2

For your first question, you can set a scheduled task to restart the Transport service, you just need to create a batch file with the following commands in it:

net stop MSExchangeTransport /y
net start MSExchangeTransport

Then set windows to run this when you want.

share|improve this answer
    
Ok thanks, I'll use this as a temporary mesure –  Philippe Feb 24 '10 at 15:43
    
I have just tried this in a batch file but it seems the service cannot be stopped using command line. The service is stopping until I get the "The service could not be stopped" message. After this, the service indeed stops but isn't restated since the batch file failed at the stopping operation. –  Philippe Feb 24 '10 at 16:46
    
You probably want sleep 180 or something like that in between the two lines. You sometimes need to give services time to finish stopping after the command returns. –  Mark Jul 25 '11 at 20:04
add comment

This script works for restarting the service. I'm having the same issue with the transport service. I have to do this every hour now.

sc stop MSExchangeTransport
sc stop MSExchangeEdgeSync

timeout /t 10

sc start MSExchangeEdgeSync
sc start MSExchangeTransport
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.