Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows XP Professional computer that needs to access a network share hosted by a Windows Server 2003 machine, but the user does not want to enter a user name and password over and over again. The XP computer is not on a domain although the server is. To set this up, we went into the dialog brought up by typing:

control userpasswords2

and then added the appropriate server name and credentials. This worked great for months and the user never had to enter a password.

Recently though, we have to enter the user name and password every time the computer is turned on.

After rebooting, any attempt to reconnect to the network share causes Windows to ask for network credentials again. If we go back to the userpasswords2 dialog, the server name and credentials we just entered are gone. When connecting to the share manually, checking the box to remember the password has no effect that survives a reboot. What happened?

share|improve this question
    
Any particular reason why the XP machine can't be joined to the domain? That would seem to be the most obvious solution. –  Darth Satan Feb 24 '10 at 18:58
    
There is a reason, though one could debate whether it was a good reason. :) I will probably press the issue if nothing else works. –  Jeremy Feb 24 '10 at 20:30

5 Answers 5

up vote 4 down vote accepted

Joining the domain is the best answer. The following works but isn't secure.

  1. Clear all drive mappings: From a CMD prompt on the wkstn type:

    Net Use * /del /Y Net Use /persistent:no

Reboot the workstation.
If the drive mapping returns then you'll need to figure where it's coming from and stop it. Make sure there aren't any other batch files running on startup, look in the startup folders & registry. Sometimes doing a "Disconnect Drive" from Windows Explorer will remove it when Net Use /del doesn't.

  1. Create a batch file and set it to run on logon:
    Save the following text as MapDrives.bat file on the wkstn in C:\Admin or somewhere that the user won't have a chance to delete it accidentally.

    Net Use * /del /Y Net use X: \ServerName\ShareName /User:DomainUser DomainPassword

Put a shortcut to MapDrives.bat in the All Users\Startup or %ThisUser%\Startup folder as you prefer. In Properties of the shortcut set it to run Minimized.

Manually run the bat file from a CMD prompt to confirm & resolve any errors.

Reboot the workstation and test again.

share|improve this answer
    
+1 exactly what I was going to say. I use a .bat in the startup on several macihnes, never had any problems –  cop1152 Feb 25 '10 at 2:32
    
Good idea. One small wrinkle I have is that sometimes this machine needs to connect to the share over a VPN, so the share is not actually available until then. Maybe a shortcut or something on the desktop to remap? I will try this if I cannot get it onto the domain. –  Jeremy Feb 25 '10 at 14:08

Try adding the credentials as stored credentials if there are none listed. It worked for me.

share|improve this answer

Are there any Group Policy Objects that may change the expected behavior? You can check by running RSOP.MSC (Resultant Set of Policy)

share|improve this answer
    
XP machine ain't on the domain so this would be the local policy only. –  Darth Satan Feb 24 '10 at 18:58
    
Are thre stored credentials that no longer match account info. In User Accounts Advanced in Control Panel –  Dave M Feb 24 '10 at 19:02

In that Control Panel applet, go to Advanced, then Manage Passwords. Delete any cached credentials you see in there, then reconnect and reauthenticate and see what happens.

share|improve this answer
    
There are no cached credentials unfortunately. –  Jeremy Feb 24 '10 at 20:39

I had the same problem but I managed to fix it by re-mapping the network drive, putting in the password and ticking the 'remember password' box. Next time i logged in I didnt need to add the administrator password. Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.