Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This server has been running like a dream since I got it about a year ago. Torrent slave, NGINX webserver, CUPS print server, game server, and it got great uptime.

This past month or so, I have started to get huge packet loss in my connections to the server. I was editing something on it with Gedit (forwarding X over SSH,) and all the sudden it locked up and started getting very unresponsive. It has basically never gotten better since then. This has gotten so bad that even text-only SSH sessions are frequently unusable. Other people joining the game server have confirmed that it is basically unplayable (one guy called it a "flashback to the 70s.") I got a new router, that didn't solve the problem. (Don't regret buying it though, it's a big improvement in other ways.) I know it's not my modem because it happens via my LAN as well.

OS is Ubuntu 8.04, which is up-to-date.

Load on the server seems fine, CPU usage is almost never over 25%, everything is normal.

My Internet connection as a whole is also fine.

CPU: Pentium II (Deschutes core) @ 400 Mhz
80 Gb HDD (new)
192 Mb RAM
360 Mb Swap

max@server:~$ lspci  
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)  
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)  
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)  
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)  
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)  
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)  
00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)  
00:14.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)  
01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)  
max@server:~$

There's a lot of different attributes of any system of course, and I'm not sure which ones are relevant-- if you need anymore information don't hesitate to ask.

Have any "old hand" Linux server admins ever seen anything like this before, and if so what caused it?

Thanks, -Max

EDIT: Error counter is pretty high:

max@server:~$ ifconfig  
eth0      Link encap:Ethernet  HWaddr 00:0e:2e:45:0c:a1    
          inet addr:192.168.1.103  Bcast:192.168.1.255  Mask:255.255.255.0  
          inet6 addr: fe80::20e:2eff:fe45:ca1/64 Scope:Link  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1  
          RX packets:9519234 errors:49527 dropped:0 overruns:1 frame:0  
          TX packets:13950328 errors:0 dropped:0 overruns:6 carrier:0  
          collisions:0 txqueuelen:1000   
          RX bytes:2429542473 (2.2 GB)  TX bytes:3878514896 (3.6 GB)  
          Interrupt:9 Base address:0xd800   
lo        Link encap:Local Loopback    
          inet addr:127.0.0.1  Mask:255.0.0.0  
          inet6 addr: ::1/128 Scope:Host  
          UP LOOPBACK RUNNING  MTU:16436  Metric:1  
          RX packets:463089 errors:0 dropped:0 overruns:0 frame:0  
          TX packets:463089 errors:0 dropped:0 overruns:0 carrier:0  
          collisions:0 txqueuelen:0   
          RX bytes:82642330 (78.8 MB)  TX bytes:82642330 (78.8 MB)  
max@server:~$   

EDIT2: Maybe this could be helpful (it is the output of netstat -ees, and it is big enough that I put it on pastebin.) http://pastebin.com/AWfkF8Vh

share|improve this question
    
"I was editing something on it with Gedit (forwarding X over SSH,) and all the sudden it locked up and started getting very unresponsive" ... what exactly where you editing, and what changes did you make? –  Zypher Feb 25 '10 at 2:14
    
Doubt that matters, but this was about a month ago so I don't remember. It wasn't any config file or anything, I remember that. (If it was, it would have been running with elevated permissions and the dark theme wouldn't have been in effect.) –  Max E. Feb 25 '10 at 2:17

2 Answers 2

Well, you don't give a whole lot of info, so all I can do is offer a suggestion. Have you tried connecting directly to the server w/ a crossover cable to see if packet loss persists? Perhaps you have a bad switch port.

share|improve this answer
    
I did get a new router, and yes I have tried this as well. Is there any info I could edit into my question which would help? Thanks for the answer. –  Max E. Feb 25 '10 at 2:41
1  
Packet captures, network interface error counters to start. It could be a bad network card - you could try throwing a cheap $15 NIC into the server and switching over to that instead of the Realtec card. –  EEAA Feb 25 '10 at 3:16
    
Cool, I'll look into that. I'm also going to get some new cable, will post if that fixed it. –  Max E. Feb 25 '10 at 3:18
up vote 0 down vote accepted

It was a bad cable.

Since I got a new router, I have had a spare, so I pulled together two short cat5 cables and setup an impromptu LAN with the server and my laptop. Everything was flawless, as good as it had ever been. (Previous tests had me using the same old broken cable connecting to my laptop instead of my router.)

I will need to run some new cable under my house and I should be good to go! Thanks for all replies and comments!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.