Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm lost at what to do about this:

Hi...

System: Windows 2008 R2 Hyper-V farm running with failover cluster with a EVA 4400 as backend.

When I attach a new disk to a VM it fails when I try to start it.

If I move the VM to another, say node 1, I can add the disk and I can get them to start.

If I move the VM back to node 2 where the problem arose and the VM is running, I get an error during live migration and the VM fails back to node1 where it did run...

So it's like there is something wrong with Hyper-V on node 2 and not node 1. Also node 3 has the same issue.

Restarting the nodes is NOT an option since I will have this problem again at a later time AND because not all the VMs can run on node 1 which means my client company will experience downtime on the VMs not running on node 1.

Any fix for this? An update I have missed perhaps? It has been two years...

Here are the errors:

An error ocurred while attempting to change the state of virtual machine XXX.  

'XXX' failed to start.  

Microsoft Emulated IDE Controller (Instance ID {83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): Failed to power on with Error 'A device attached to the system is not functioning.'  

Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.'  

Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.'  

'XXX' failed to start. (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

Microsoft Emulated IDE Controller (Instance ID {83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): Failed to power on with Error 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

'XXX': Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

'XXX': Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08) 
An error ocurred while attempting to change the state of virtual machine XXX.  

'XXX' failed to start.  

Microsoft Emulated IDE Controller (Instance ID {83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): Failed to power on with Error 'A device attached to the system is not functioning.'  

Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.'  

Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.'  

'XXX' failed to start. (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

Microsoft Emulated IDE Controller (Instance ID {83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): Failed to power on with Error 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

'XXX': Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

'XXX': Failed to open attachment 'X:\XXX.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08) 
An error ocurred while attempting to change the state of virtual machine XXX.  

'XXX' failed to start.  

Microsoft Emulated IDE Controller (Instance ID {83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): Failed to power on with Error 'A device attached to the system is not functioning.'  

Failed to open attachment 'c:\clusterstorage/volume1/XXX.vhd'. Error: 'A device attached to the system is not functioning.'  

Failed to open attachment 'c:\clusterstorage/volume1\XXX.vhd'. Error: 'A device attached to the system is not functioning.'  

'XXX' failed to start. (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

Microsoft Emulated IDE Controller (Instance ID {83F8638B-8DCA-4152-9EDA-2CA8B33039B4}): Failed to power on with Error 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

'XXX': Failed to open attachment 'c:\clusterstorage/volume1\XXX.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08)  

'XXX': Failed to open attachment 'c:\clusterstorage/volume1\XXX.vhd'. Error: 'A device attached to the system is not functioning.' (0x8007001F). (Virtual machine 36563C78-65B5-4C40-A52D-689BB39E8B08) 

In the Hyper-V logs I found some more errors:

In the hyper-v VMMS logs I have this:

'ServerName' failed to perform the operation. The virtual machine is not in a valid state to perform the operation. (Virtual machine ID 0A6CC4A9-39D6-4413-8CF0-B6DAA35B68D7)

share|improve this question
add comment

1 Answer

does your storage pass the cluster validation test? The only time I have a problem with live migration is when I mount a dvd/iso or something thats not on the CSV or shared storage. The key is CSV or SHARED storage.

somethings fishy when you see x:\xxx.vhd then later see c:\clusterstorage/volume1

the only failures that I've seen with a couple hundred hyper-v r2 CSV installs is human mistakes!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.