Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I Added FTP to a site on IIS7 in windows 7 in order to test ftp operation performed by another website (also under IIS 7). The problem is that when i try to access the ftp site using my web browser and ftp://ftp.mysite.com it directs me to the real ftp site online even after adding an entry to the Host file. Is it possible to do what i am trying to achieve?

my entry in the host file looks like this: 127.0.0.1::21 ftp.mysite.com

share|improve this question

1 Answer 1

Possibly becuase your syntax is wrong. The port number should not be in the hosts file, as that file is only used for, well, hostname resolution.

127.0.0.1 ftp.mysite.com
share|improve this answer
    
sorry i should have mentioned that i tried every possible combinations i could think of. The one you suggested return me "server not found" –  ak3naton Feb 25 '10 at 20:03
    
In that case, it sounds like there's most likely a configuration problem with your FTP server. –  EEAA Feb 25 '10 at 20:13
    
If the hosts file doesn't appear to be working, check your proxy settings. They could be ignoring your hosts file. –  Milner Feb 25 '10 at 20:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.