Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently bought a Linksys WMP110 wireless PCI NIC for my XP machine. It works fine, except when I take it out of hibernate it sometimes won't reconnect or even see any wireless networks. I have to reboot for it to work again.

I figured there might be a driver setting that can be tweaked to fix it, but I'm not sure what that setting might be. I'm using the latest driver for the card (1.1.2). I have a built-in Ethernet interface and a regular PCI Ethernet card in the machine, but both are disabled. Any idea why this would randomly happen?

share|improve this question
    
See this for similar problem - serverfault.com/questions/11765/… –  Piotr Dobrogost May 24 '09 at 19:29
    
On a sidenote, this card will cause troubles under Linux. The madwifi project is currently developing a new driver, so there's hope. –  Ced Jun 19 '09 at 7:44
add comment

2 Answers 2

First thing to check is that the computer is not set to turn it of to save power:

  • Open device manager
  • Expand Network Adapters, right-click your Linksys Wireless device, and then click Properties.
  • Click the Power Management tab.
  • The Allow the computer to turn off this device to save power check box is displayed, make sure it is unchecked.
share|improve this answer
    
I don't actually have a Power Management tab when I go to the properties dialog for the wireless NIC. There's an Advanced tab with a couple dozen NIC-specific settings. I tried changing one labeled CAM When AC Power to Enabled, but that didn't seem to make a difference. –  Chris Tybur May 28 '09 at 13:58
add comment

I had this problem with Vista, but not XP. When I would come out of hibernate, it would take 5-10 minutes to connect back to the wireless. I disabled Ipv6 and it sped the process to 2-5 minutes! In my mind, that was still too long. The next idea I tried was to disable the security on my wireless router. That fixed the problem instantly. I WAS using WPA2, but it takes so long to reconnect so I had to downgrade to WPA. I know this is a bad idea, but I couldn't take the delay anymore.

share|improve this answer
    
The network I'm connecting to isn't mine, and they are using WEP. I would try to get WPA working but I don't want to make major changes to the network. I have a feeling if I waited long enough mine would reconnect as well, since if I try to repair the connection it starts to work. I'll probably have to live with not hibernating for now. –  Chris Tybur May 28 '09 at 14:05
    
Try disabling IPv6. –  Jacob Jun 24 '09 at 18:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.