Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Apache server on Windows 7. When I try to access the server by its IP address I get in Chrome:

Forbidden

You don't have permission to access / on this server.

In IE I get:

The website declined to show this webpage
HTTP 403 Most likely causes:
•This website requires you to log in.

I want to emphasize that I get another message if I type arbitrary IP. So, the server is working it just does not want to show me files.

I checked already ports (port 80 is opened, I think). And in my "httpd.conf" file I have "Listen 80".

At the moment I think that the problem is in permissions to files and folders. Can anybody tell me how can I check the permissions of files and folders, how can I change them (DOS analog of Linux's chmode), and which permission I need to set (so that people from outside can see my files but they cannot do something bad).

Thank you in advance for any help.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

This could be permissions-related, but in most cases, I'd say it's caused by not having a index.html file at your DocumentRoot, and not having Options Indexes enabled. (What is your DocumentRoot, anyhow?) From Wikipedia:

[403] is returned by the Apache web server when directory listings have been disabled.

share|improve this answer
add comment

The command you want is cacls - run it in command prompt and check the options. You could right click the folder > properties, and change the permissions in here too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.