Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Python 3 web app so mod_wsgi < 3.1 doesn't cut it for me. However, on my Ubuntu 9.10 installation there doesn't seem to be a package for mod_wsgi 3.1.

  1. Is there an alternative repository that has a package for mod_wsgi 3.1?
  2. There's a new Ubuntu release not so long from now, will it contain mod_wsgi 3.1?
  3. Some other distro ready with mod_wsgi 3.1 to recommend?
  4. Maybe my best bet is to compile it myself? From a quick google it looks like I only need the python and apache dev packages installed.

Thanks!

share|improve this question
add comment

1 Answer

For question 2, it looks like Lucid (10.04) will have 2.8. Probably compiling it yourself should not be too difficult.

share|improve this answer
    
Which is sad in itself given that even Ubuntu and Redhat Fedora have mod_wsgi 3.2 in their repositories now. Ubuntu just isn't keeping up these days if they only have mod_wsgi 2.8. :-( –  Graham Dumpleton Apr 12 '10 at 5:37
    
Graham, ubuntu has packages for 3.2 and 3.3, but note that his asking about ubuntu version 9.10 means he is asking about ubuntu released in October, 2009 –  stew Dec 13 '11 at 18:50
    
The answer was saying that 10.04 at the time would still only have 2.8. –  Graham Dumpleton Dec 15 '11 at 2:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.