Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Sorry I'm still a bit of a novice with dedicated hosting. Anyway, we have a dedicated server running cPanel and WHM. I have full terminal access and all that.

Basically I've tried to install Chive to a user on my server's account. Unfortunately whenever I login with any details, I get the following error:

Internal Server Error

include(PDO.php) [<a href='function.include'>function.include</a>]:

failed to open stream: No such file or directory

An internal error occurred while the Web server was processing your

request. Please contact the webmaster to report this problem.

Thank you.

My research shows from that --disable-pdo is in the Configure Command list. What I want to know is how can I change this and turn it off? I have these two lines at the end of my php.ini file:

extension=pdo.so extension=pdo_mysql.so

(There's a linebreak between them but SF isn't showing it...)

But still it's not working. I can't find anywhere in php.ini that defines --disable-pdo - so where do I change this?

Thanks!

Jack

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Hi :) try this : http://www.webhostingtalk.com/showthread.php?t=680039

share|improve this answer
1  
Thanks, great link, all working now :) –  Jack W Feb 26 '10 at 20:40
1  
thank you. helped me solve my problem too. :) –  Ibrahim Azhar Armar Oct 14 '12 at 1:43
    
Thanks also. You beauty! –  Jayden Lawson Sep 6 at 11:17

That statement isn't showing PDO is not compiled (though it looks like it isn't) it is stating that some PHP script is trying to include a file called PDO.php. What line or file is given? It looks like you edited the message.

share|improve this answer
    
No, I didn't edit the message. It came straight out of Chive (chive-project.com), an Ajax-based alternative to phpMyAdmin. It used PDO but I've got the problem sorted now, thank you. –  Jack W Feb 26 '10 at 20:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.