Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a very annoying problem with fedora core 8. I am not able to install git it gives this error every time I do a yum install git-core

Error: Missing Dependency: libcurl.so.3 is needed by package git

There seems to be no way of resolving this dependency as FC8 has libcurl.so.4 by default and git doesn't seem to have any version that supports this version of libcurl.

Any help on how to get git installed in FC8 is appreciated.

share|improve this question
    
How did you end up resolving this? I'm having the exact same problem. You said in a below comment that you used a different version of git. What version? And did you install from an RPM, from source, or some other way? And was it git or git-core? –  Schrockwell Oct 30 '10 at 2:08

2 Answers 2

You should be able to kludge this by making a symlink for the missing dependency:

sudo ln -s /usr/lib/libcurl.so.4 /usr/lib/libcurl.so.3

However, you may well get more of these dependency issues trying to install newer packages such as Git on such an old version of Fedora Core. Are you unable to upgrade ?

share|improve this answer
    
Didn't work out. Any ways I solved the problem by finding a version of git which could work with libcurl.so.4 –  GeekTantra Feb 28 '10 at 13:36

You could also try to download the source rpm and rebuild with rpmbuild --rebuild git-*.src.rpm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.