Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just did a fresh base install of fedora 12, and did a yum install 389-ds. I went through the included setup script ( and everything started fine and was working normally. I could access the directory server and login using the directory manager account created during the setup.

After a reboot I tried starting the dirsrv service using the following command:

[root@test-ds ~]# /etc/init.d/dirsrv-admin start
Starting dirsrv-admin:                                  [  OK  ]
[root@test-ds ~]# /etc/init.d/dirsrv start
Starting dirsrv: 
[26/Feb/2010:14:59:11 -0500] dse - The entry cn=config in file
/etc/dirsrv/slapd-test-ds/dse.ldif is invalid, error code 53
(DSA is unwilling to perform) - nsslapd-errorlog-mode: Failed to chmod
error log file to 600: errno 1 (Operation not permitted)

[26/Feb/2010:14:59:11 -0500] dse - Could not load config file [dse.ldif]
[26/Feb/2010:14:59:11 -0500] dse - Please edit the file to correct the
reported problems and then restart the server.
  *** Warning: 1 instance(s) failed to start

If I turn off SELinux with "setenforce 0", it can start without any issue. There are no entries generated in /var/log/audit/audit.log like I'd normally see for an SELinux error but it's infinitely repeatable turning SELinux on and off with setenforce.

share|improve this question
up vote 1 down vote accepted

This is a known bug.

Try updating your SELinux Policy to minimum 3.6.32-59.

share|improve this answer
Thanks that was it! I tried searching for known bugs but I didn't stumble across this one because I assumed it would still be marked as 'open'. Oh well, Thanks again! – TrueDuality Mar 1 '10 at 13:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.