Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Hope you can help me, up until last night all sites on my server were displaying fine but now whenever you visit any of them you get the default - "Welcome to Your New Home in Cyberspace!" page - all the domains are setup right, have been working and were working until last night and i haven't edited any of the apache files so i really can't see why they have broken, i am using Debian and all the sites have been activated

Really hope someone can help me David

share|improve this question

migrated from stackoverflow.com Feb 27 '10 at 9:43

This question came from our site for professional and enthusiast programmers.

    
Could you provide some more information ? What do the apache access and error logs say ? How about the servers uptime ? –  Dominik Feb 26 '10 at 17:23
    
That's an odd default landing page for Apache. Do you have access to the apache conf file? Are you looking for responses only from people named David ;)? –  Patrick R Feb 26 '10 at 18:27
    
the server is up and running, all the files are on the server, it is like someone has told the server to look in another folder for the websites - i stored the sites in /home/username/domain1.com and that works fine up until now, that doesn't see to matter anymore, but i have found out if i upload files into /var/www they show up - what is going on ? –  David Feb 26 '10 at 19:01
    
make sure the domain is pointing to your server ip –  Prix Aug 25 '10 at 4:20
    
What else happened when it stopped working? Did you restart a service, en ble a new site, reboot the machine, ...? –  Joris Aug 25 '10 at 4:40

3 Answers 3

We would need some more information:

  • the apache config files
  • the apache logfiles
share|improve this answer

Do you have UserDir directive in your apache configuration file ? If yes, make sure it's not disabled or comment out and 2nd UserDir is pointed to your web directories.

For example: UserDir enabled UserDir /home/*/domain1.com

share|improve this answer
rm /etc/apache2/sites-enabled/default
/etc/init.d/apache2 restart

check /etc/apache2/ports.conf, make sure NameVirtualHost *:80 is still there and isn't commented out.

Are your site configs still in /etc/apache2/sites-enabled? did you put them somewhere else? did the line that includes /etc/apache2/conf.d/*.conf disappear from /etc/apache2/apache2.conf?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.