Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server running gitosis (installed from the package manager) on Debian Lenny. I am able to perform all operations from my linux mint laptop, but from my Mac running an up-to-date Snow Leopard gives me the following error:

mica@waste Desktop$ git clone gitosis@
Initialized empty Git repository in /Users/micas/Desktop/Poems/.git/
ERROR:gitosis.serve.main:Repository read access denied
fatal: The remote end hung up unexpectedly
mica@waste Desktop$ ssh -v gitosis@
OpenSSH_5.2p1, OpenSSL 0.9.8l 5 Nov 2009
debug1: Reading configuration data /etc/ssh_config
debug1: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /Users/micas/.ssh/identity type -1
debug1: identity file /Users/micas/.ssh/id_rsa type 1
debug1: identity file /Users/micas/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5
debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '' is known and matches the RSA host key.
debug1: Found key in /Users/mica/.ssh/known_hosts:5
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering public key: /Users/mica/.ssh/id_rsa
debug1: Remote: Forced command: gitosis-serve mica@waste
debug1: Remote: Port forwarding disabled.
debug1: Remote: X11 forwarding disabled.
debug1: Remote: Agent forwarding disabled.
debug1: Remote: Pty allocation disabled.
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug1: Remote: Forced command: gitosis-serve micas@waste
debug1: Remote: Port forwarding disabled.
debug1: Remote: X11 forwarding disabled.
debug1: Remote: Agent forwarding disabled.
debug1: Remote: Pty allocation disabled.
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Requesting
debug1: Entering interactive session.
debug1: Requesting authentication agent forwarding.
PTY allocation request failed on channel 0
ERROR:gitosis.serve.main:Need SSH_ORIGINAL_COMMAND in environment.
                                                                  debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: client_input_channel_req: channel 0 rtype reply 0
debug1: channel 0: free: client-session, nchannels 1
Connection to closed.
Transferred: sent 2544, received 2888 bytes, in 0.1 seconds
Bytes per second: sent 29642.1, received 33650.3
debug1: Exit status 1

Extensive googling of the error isn't returning much-- I changed the /etc/sshd_config file on my Mac as per I still get the same error.

share|improve this question
Is there already a Poems.git repository there for you to clone? Does either of the users mica or micas have read permission on it in gitosis.conf? – Novelocrat Feb 28 '10 at 0:19
Yeah, the poems.git repo is there, I can pull all my repos to my linux laptop. in my gitosis.conf, the micas & mica user has permissions to all repos. – Mica Feb 28 '10 at 0:27
and... this was working while i was running leopard. i've already switched rsa keys. – Mica Feb 28 '10 at 2:04
was it sshd_config or ssh_config that you edited? – quadruplebucky Mar 1 '10 at 2:55
turns out i didn't need to actually edit either; i had my list of users in the gitosis.conf file seperated with commas, however the users are space seperated. so gitosis was looking for user@domain, instead of user@domain – Mica Mar 29 '10 at 18:19
up vote 0 down vote accepted

As it turns out, gitosis is no longer maintained, i will be moving to gitolite soon. My problem was that i was using a comma to separate the users in my gitosis.conf file, but users should just be space separated.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.