Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

At the moment I cannot use sqlite from PHP. Probably I need to change something in my php.ini file. In my php.ini file I found 2 lines containing "sqlite":

[sqlite]
;sqlite.assoc_case = 0

Does semicolon in front of the line means that line is commented? Should I uncomment the second line? Should I change the value of the "sqlite.assoc_case" from 0 to something else?

P.S. I have 2 php.ini files:
/etc/php5/apache2/php.ini
/etc/php5/cli/php.ini
which one should I change?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Have you tried my suggestion in your other question to install the php5-sqlite package?

What you're looking for in php.ini once this package is installed is a line similar to extension=sqlite.so (the module name may be slightly different.)

The options in the [sqlite] section just change the options when SQLite is in use correctly.

Yes a ; in front of a line is a comment.

The file you want to change is the one Apache is using (if you're using accessing your PHP script through a web browser.)

share|improve this answer
    
I just tried to install php5-sqlite and got the following: Building dependency tree Reading state information... Done Package php5-sqlite3 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package php5-sqlite3 has no installation candidate –  Roman Feb 28 '10 at 12:07
    
I have installed php5-sqlite (not php5-sqlite3) and it worked. Thank you very much! –  Roman Feb 28 '10 at 14:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.