Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I use Elastic IPs in I can't use SSH. When I try to login, following message is show

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that the RSA host key has just been changed.
share|improve this question
    
What is your question? –  John Gardeniers Mar 1 '10 at 10:17
    
I got it. after edit .ssh/known_hosts and it's OK,now. –  saturngod Mar 2 '10 at 17:13

2 Answers 2

up vote 3 down vote accepted

Edit your .ssh/known_hosts file and delete the line corresponding to your AMI.

The problem is that the first time you connected, ssh saved the remote key of that machine you connected to, and when you enabled Elastic IPs, that remote key changed.

http://developer.amazonwebservices.com/connect/thread.jspa;?messageID=104781𙥍

share|improve this answer

Alternatively, use ssh-keygen -R <hostname|IP address> to remove the entry from the known_hosts file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.