Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to tell a server 2008 R2 machine to NOT register it's IP addresses in DNS. I go into the Advanced tab on IPv4 and turn off "Register this connection's addresses in DNS" simple! But... the addresses are updated in DNS anyway! And actually the A record is eventually removed from the DNS server.

I've confirmed that the checkbox is off by looking at it myself, and by checking the RegistrationEnabled registry value for that adapter. Both confirm that the registration is off.

I've turned of DNS debug logging on the DNS server and I can see DNS Update requests coming from the server in question! This should not happen.

What's even odder is that eventually (several hours) the A record for the server (which I added by hand!) is removed from the DNS server. I've also confirmed that scavaging is off on both DNS servers in the domain.

Ideas?

Edits: Per the comment: The server has static IP addresses. However, it's got two of them on one adapter.

Since I'm in a VM (HyperV) environment I just spun up a second adapter and moved the second IP to the second adapter. I set the first adapter to auto-register (since that's the IP I want anyway) and the second adapter to NOT auto-register. We'll see if this is any better.

Not any better. On a reboot of the server the registration was removed from DNS. Seems both cards are still contacting the server. Based on the DNS log the card that shouldn't register in DNS is registering a 'delete' request. And then the card that should register is registering an add request but that's ignored. I'm totally confused at this point.

share|improve this question
    
Does the server have a static IP or use DHCP? –  Sim Mar 2 '10 at 3:09
    
Sorry to all for the delays in responding, didn't get notifications that there were updates.... stupid spam filters! :-) –  WaldenL Mar 15 '10 at 16:04
add comment

4 Answers

up vote 2 down vote accepted
+150

Try it through the command line and see if that helps.

netsh interface ipv4 set dnsserver name="Local Area Connection" source=static address=IPofDNSServer register=DNSRegisterOption

Where IPofDNSServer is the IP Address of the DNS Server you want to use and DNSRegisterOption can be:

None Specifying Register=None would result in your Server Core box not registering its DNS name with any of its DNS suffixes. This effectively disables Dynamic DNS Registration.

Primary With Register=Primary your Server Core installation will register its hostname together with its primary DNS suffix with the DNS Server you set.

Both When you tell your Server Core box to Register=Both it will register its hostname with its primary DNS suffix and the connection specific DNS suffix with the DNS Server you set.

share|improve this answer
    
Will give it a shot and update. –  WaldenL Mar 15 '10 at 16:03
add comment

As per Microsoft KB Article Q246804 create the followind DWORD value HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\DisableDynamicUpdate and assign a value of 1.

Then add a static entry in dns whith the hostname and ip address you need, and you are done.

The KB article is for Windows 2000, 2003. But I had the same problem and solved it doing this.

share|improve this answer
add comment

If you have the server set to not register with DNS, you actually need to create a manual (static) DNS entry for this IP.

I'd recommend removing the second interface. Have your single interface not register and create a static entry.

share|improve this answer
    
Yes, I agree that if it's set to not register then you need to create a static entry, but that's what I did, and I can still see DNS updates in the DNS log. It's as if Widows is updating anyway. Very odd. Bug? –  WaldenL Mar 15 '10 at 16:03
add comment

This could be Windows DHCP updating DNS. If you use Windows DHCP, check to see if it is set to update your DNS in the setting for the DHCP role service.

share|improve this answer
    
This server isn't DHCP, but if it was that would be a good idea. –  WaldenL Mar 15 '10 at 16:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.