Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, I have never tried to install Ubuntu to a RAID setup before.

I am running a Supermicro X8DT3-LN4F motherboard with onboard Adaptec RAID controller with six 160GB drives attached to form a RAID10. Status of the RAID set is OPTIMAL.

I try to install Ubuntu 9.04 server, however when I get to disks detection phase, Ubuntu reads all 6 drives as separate 160GB drives instead of a single RAID 10 480GB set.

I tried going ahead and installing to one drive just to see what would happen, and as expected, not much.

Searching around I can't seem to find anybody who has experienced this sort of thing.

On other systems where I was using a different kind of raid controller, I never experienced this. The raid set always came up as a single drive. But I was never trying to install Ubuntu to the raid sets in the past.

I have already put in an email to tech support, but I wanted to see just how deep the rabbit hole goes here at serverfault :)

Can anybody tell me what is going wrong here?

share|improve this question
Additional information - Ubuntu 9.04 cannot read ICH10R raid properly. I found reference to this in bug reports. I am going to try kramic and see if it has more support for newer chipsets vs. jaunty. – JonathanLIVE May 25 '09 at 1:43

i've taken a look at mb specs. have you by any chance connected disk to ICH10R ports ?

what you describe sounds very much like there is soft-raid not a 'real raid' in use. those works fine with windows but do 'heavy lifting' [ xoring for raid5 ] on your main cpu instead of dedicated controller.

share|improve this answer
There are only 1 set of ports on the motherboard.. six ports.. then with the bios settings you can specify either None, Intel, or Adaptec ICH10 raid. I tried Intel first and had the same sort of thing roughly happen. – JonathanLIVE May 24 '09 at 21:48
up vote 1 down vote accepted

Hate to say it.. but the Supermicro X8DT3-LN4F and all their new motherboards don't have Ubuntu support. The only drivers available are for RH or Suse.

On a side note... the onboard controller that comes with most motherboards is also called a 'fake raid' by some. There is more details on this provided in Ubuntu help area:

The end result was that I needed to drop the onboard raid and stick to native sata.

If I want RAID in the future I will need to buy a card.

Hope this helps

share|improve this answer
Just use Linux software RAID. Especially for RAID10, hardware RAID really can't help you (unless its really expensive and has a battery) – derobert Jun 13 '09 at 4:36

You need to install the raid driver so that linux recognizes the array as 1 drive instead of 6.

This [chart] says it supports Ubuntu 8.x without raid support.

Try going to SuperMicro's [support site] to download raid drivers for linux. It doesn't specifically support Ubuntu but I would think you can install another distro's driver. they have one listed under Suse Linux 9, and probably other places.

share|improve this answer
Yeah.. I took a look and I only see support for Redhat and Suse in terms of drivers they have available... looking at the legend.. I don't understand why 32bit would be supported and not 64bit. :( After the other answer I looked a little more into ICH10R and ubuntu and I found out I was not alone.. I have found something and am about to test it.. will report results soon. – JonathanLIVE May 24 '09 at 23:52

What you call "fake RAID" is now in many professional rackmounts with standard chipsets. It has shortcomings but for many applications including RAID-1, it does a very good job.

Defining the problem away by discrediting the hardware as "fake RAID" makes it difficult to take Ubuntu Server seriously, and makes it seem like the "fake" in the equation.

I've read that there are "alternate ISO" distributions of 9.04 that work fine on these systems, I'm going to go look for one.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.